PDA

View Full Version : [SOLVED] 11.04 Slow wireless connection using ath9k drivers.



silkworm2.5
May 1st, 2011, 11:41 PM
Hello Everyone! :)

Title pretty much says it all. Since upgrading to Ubuntu 11.04 my wireless connection has been extremely slow. The same happened with 10.10. Although that was quite different. Back then everything within my network moved slowly, but now it doesn't affect my web browser.
It seems to have only slowed the application centre and update manager. I am still waiting for the flash plugin to download and install for testing youtube, but I am torrenting Ubuntu 11.04 right now and have actually hit the limit of my bandwidth (1.1 MB/s) whereas the speed in the software centre and update manager was in the region of 45 kb/s.

I'm not sure if this is because I have installed extra drivers found here (http://wireless.kernel.org/en/users/Download#Directly_downloading_the_tarball) after I did some research.

Although my web surfing is fast and stable, I would like to get my updates and applications downloading properly. Does anyone know what I can do?

From my 2-hour googling spree I know you may want the results from the command "lspci" :P



root@Felicia:/home/silkworm# lspci
00:00.0 Host bridge: Intel Corporation Mobile 4 Series Chipset Memory Controller Hub (rev 07)
00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
00:02.1 Display controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
00:1a.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 (rev 03)
00:1a.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 (rev 03)
00:1a.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 (rev 03)
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 (rev 03)
00:1c.1 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 2 (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 (rev 03)
00:1d.3 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 93)
00:1f.0 ISA bridge: Intel Corporation ICH9M LPC Interface Controller (rev 03)
00:1f.2 SATA controller: Intel Corporation ICH9M/M-E SATA AHCI Controller (rev 03)
00:1f.3 SMBus: Intel Corporation 82801I (ICH9 Family) SMBus Controller (rev 03)
00:1f.6 Signal processing controller: Intel Corporation 82801I (ICH9 Family) Thermal Subsystem (rev 03)
02:00.0 Network controller: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) (rev 01)
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 02)

Any help would be greatly appreciated ^_^

And by the way, a little off topic, but is downloading apps through Ubuntu Tweak just another interface for apt-get? Because that has the same speed as the software centre.

malbicho
May 3rd, 2011, 03:34 PM
Hi, try this is well explained:
http://linuxwireless.org/en/users/Download#Directly_downloading_the_tarball

I had the same problem with ath9k and it worked for me

OOHHOO
May 3rd, 2011, 10:34 PM
hi,

i have the same problem. 11.04 has turned my high speed wifi into a slow dialup style connection. i conect to my wireless router just fine but when i try to load a page, it just sits there loading and takes a long time or it just stops loading altogether.

unfortunately i have no clue what to do at the link. i don't know how to compile a tarball thing or where to put those scripts.

is there an easy way to ugrade my drivers for the ath9k? :(

thanks in advance for any help.

yellerKat
May 3rd, 2011, 10:44 PM
See this post here: LINK (http://ubuntuforums.org/showpost.php?p=10757804&postcount=25)

Basically all you have to do is:


sudo -s

echo "options ath9k nohwcrypt=1" > /etc/modprobe.d/ath9k.conf


and reboot!

(Thanks to mantaor and Andrea!)

OOHHOO
May 3rd, 2011, 11:37 PM
Thank you so much !! :D

it worked!! i truly appreciate your help.

i hope you have a wonderful week.


thank you again!!

wburden
May 4th, 2011, 03:15 AM
Thank you "Yellercat"! This solution worked flawlessly for me also.

Just a slight addition to your solution - you can type "reboot" as step 3 from terminal to initiate the reboot process. Thank God for Ubuntu Forums.


See this post here: LINK (http://ubuntuforums.org/showpost.php?p=10757804&postcount=25)

Basically all you have to do is:


sudo -s

echo "options ath9k nohwcrypt=1" > /etc/modprobe.d/ath9k.conf


and reboot!

(Thanks to mantaor and Andrea!)

mcongom
May 6th, 2011, 01:32 AM
See this post here: LINK (http://ubuntuforums.org/showpost.php?p=10757804&postcount=25)

Basically all you have to do is:


sudo -s

echo "options ath9k nohwcrypt=1" > /etc/modprobe.d/ath9k.conf


and reboot!

(Thanks to mantaor and Andrea!)

Thanks!!! It also worked for me!!!!

fgm@osinet.fr
May 6th, 2011, 09:02 AM
Using this nocrypt option actually restores speed, but my machine then crashes completely after a variable duration, from a few seconds to a few minutes. It then needs a hard reboot. This does not happen when nocrypt is not used (and wifi is then slow enough to get timeouts on most transmissions).

silkworm2.5
May 8th, 2011, 12:51 PM
Thanks for that response yellerKat! That fixed it right up this time!

quantumriff
May 14th, 2011, 06:04 PM
FYI, I just installed the newest kernel (2.6.38-9.43) that is in the ubuntu-proposed update tree, and it seems to fix the issues with the ath9k driver. My Acer laptop is usable on wireless again!

digitalpure
May 29th, 2011, 06:57 AM
I wish this would have fixed my issues. I might need to go back to 10.10 which was wonderful. I upgraded my kernel to 2.39.x also and still no go.

evanct
June 1st, 2011, 07:36 AM
Yeah, yellerkat's fix doesn't help me either. Neither does updating my kernel. this is kind of driving me crazy.

attam
June 15th, 2011, 11:49 PM
Thanks a lot...Worked for me like a charm!

pandazxx
July 1st, 2011, 05:53 PM
Thank you! This works very great!

saggz
September 19th, 2011, 02:14 AM
THANK YOU!!!

Funny how a simple command can get my internet back to normal speed, I have 40mbps internet and I was getting 10kb/s at first when I tried to get updates, I did this and now I am back to <500kb/s

Thank you so much!

Rodney9
October 22nd, 2011, 07:38 AM
sudo -s

echo "options ath9k nohwcrypt=1" > /etc/modprobe.d/ath9k.conf

Thank You this worked for me as well

metafaniel
December 10th, 2011, 02:14 AM
HI! I don't post so much in these forums, I just read, find solutions and tweet some useful threads but this solution was so flawless, fast and simple that I just needed to say THANKS A LOT.
5 STARS RANKING :KS:KS:KS:KS:KS


See this post here: LINK (http://ubuntuforums.org/showpost.php?p=10757804&postcount=25)

Basically all you have to do is:


sudo -s

echo "options ath9k nohwcrypt=1" > /etc/modprobe.d/ath9k.conf


and reboot!

(Thanks to mantaor and Andrea!)

ZeroFossilFuel
December 11th, 2011, 04:50 PM
I'm glad nohwcrypt worked for some. Did nothing for me. My system is ASUS 1018P with ath9k driver, Xubuntu 11.10 3.0.0-14.

I just installed a Belkin N300 F9K1002v2 router to my Comcast modem. I have two Linksys WRT54G loaded with DDWRT v23sp2 configured as client bridges from the Belkin. Both of them clock 20mb/S down and 3.5mb/S up at 60' through 3 walls. If I connect my ASUS via eth0 to a rj45 port I get 24mb/S down. Best speed I can get wireless with the ASUS is ~5mb/S down even at very close range.

I had to sacrifice WPA in favor of WEP 128 to get everything to play nice together. The netbook wireless "seems" faster if I set the router to WPA but I lose the client bridges. The reason I don't use the latest and greatest DDWRT version is because from v23sp3 and up the client bridge feature is broken. Giving up my wireless to Ethernet bridges is not an option.

Funny thing, and I'm not sure if this is related, is every now and then I seem to get connected to an SSID named RT2860AP1 even though my SSID is totally unique and still on the list of available networks. The router uses the Ralink chipset and somewhere along the way gets confused and sends me a bogus SSID.

My ath9k should be able to get similar speeds as my client bridges but it won't using WEP. Ideas anyone?

P.S. I just tried running these same tests booted into my winblows 7 partition and it was no better. Starting to get a bad feeling about this.

ZeroFossilFuel
December 14th, 2011, 01:00 AM
I found my problem! I was tipped off by this page in some older Ubuntu docs. https://help.ubuntu.com/community/WifiDocs/Device/Atheros/AR9285 Searching in Synaptic for...

"linux-backports-modules-wireless" turned up this...
linux-backports-modules-cw-3.1-oneiric-generic

Make sure you have backports enabled in the repositories then install it. Worst that can happen is you uninstall it and you're back where you started. I'm now regularly seeing 12.5mb/S download speed. Still not as fast as my WRT54G's as client bridges but good enough. Hope this tip helps a few of you. worked for me!

BTW, i did not remove the nohwcrypt=1. I figure it couldn't hoit.

benloyola
February 15th, 2012, 11:32 PM
See this post here: LINK (http://ubuntuforums.org/showpost.php?p=10757804&postcount=25)

Basically all you have to do is:


sudo -s

echo "options ath9k nohwcrypt=1" > /etc/modprobe.d/ath9k.conf


and reboot!

(Thanks to mantaor and Andrea!)
thank you, it worked perfectlly, even though i have the ath5k driver, so i just changed the code to:

echo "options ath5k nohwcrypt=1" > /etc/modprobe.d/ath5k.conf

gishaust
May 9th, 2012, 10:22 AM
I have been fight my wireless card on ubuntu 12.04 for the last three days and this worked perfectly



sudo -s

echo "options ath9k nohwcrypt=1" > /etc/modprobe.d/ath9k.conf



all I can say is :guitar:):P=D>=D>=D> =D>

Oph5pr1n6
May 26th, 2012, 07:43 AM
sudo -s

echo "options ath9k nohwcrypt=1" > /etc/modprobe.d/ath9k.conf
What does this code actually do?
It looks to me like it disables encryption.
I'm not sure I want to do that with a wireless connection.
What am I missing?

wildmanne39
May 26th, 2012, 07:46 AM
Hi, it changes encryption from hardware to software but it does not turn it off, and for this to help you must have this driver.
Thanks

agupta
June 24th, 2012, 03:13 PM
Basically all you have to do is:


sudo -s

echo "options ath9k nohwcrypt=1" > /etc/modprobe.d/ath9k.conf
and reboot!



I am using Sony vaio y series with artheros wireless card and I faced a significant slowdown in wifi network. The above solution worked for me if I give the following commands.


sudo rmmod ath9k
sudo modprobe ath9k nohwcrypt=1


I didn't find /etc/modprobe.d/ath9k.conf in my laptop to make my commands permanent.

Thanks!

wildmanne39
June 24th, 2012, 06:41 PM
Hi agupta, just run this command and it should create the file.

sudo -s

echo "options ath9k nohwcrypt=1" > /etc/modprobe.d/ath9k.conf
Then reboot
Thanks