View Full Version : [SOLVED] Switched to Natty - lost wireless!

May 1st, 2011, 10:23 PM
Oh, I am a stupid, stupid man. I foolishly upgraded to Natty without first researching possible pitfalls. Now I am thoroughly hose-ified. This is where I sit....

I am running a Compaq Presario C500. I had to install a broadcom? driver in order to get wireless working the last time, and I just assumed ( I know... I said I was stupid ) that the upgrade would be compatible with the older driver. Alas, no. My network card is lost in limbo. I tried to follow the handy Help section but that was worthless. I followed instructions until it said to see the Device Drivers section for more help, which was kinda funny since I was actually in the Device Drivers section at the time. Anyway, when I search for 3rd party drivers on my system it finds the Broadcom driver and says that it is active and working properly, yet I have no wireless. Even the little wireless light on my keyboard is off.

I tried to wade through the Broadcom sticky up top, and got nowhere. For starters that appeared to be primarily for Dell computers, but I tried to install the updated installer as per the thread but received and error message that it could not be installed.

So... help?!?

May 1st, 2011, 10:53 PM
Further bad news type stuff. I tried to uninstall / reinstall the broadcom STA driver that I am using. No dice. Every time I try to remove the driver the system considers my request for a time and then returns the following:

SystemError: installArchives() failed

So... I have a driver that the system thinks is working, but isn't. I can't remove the driver, and the fact that I can't remove the driver would seem to point to a deeper issue. Is there anyway to just roll back the upgrade?

May 2nd, 2011, 02:43 AM
For those who are finding no love in the sticky at the top of the forum, this link provides the way, the truth, and the light. Many thanks to Rifester for pointing me there and talking me through it.