View Full Version : [ubuntu] "Module is unknown" login error after update to 11.04

May 1st, 2011, 08:27 PM
Hi everyone,

I've just upgraded to Natty and lost ability to login through the Gnome login screen - "Module is unknown" message appears after I enter the correct password and hit "Enter".

I'm still able to switch to a text console and login there, both as root and as a restricted user.

Here is an excerpt from my /var/log/auth.log file:

May 1 14:12:09 HomeServer gdm-session-worker[1948]: PAM unable to dlopen(/lib/security/pam_listfile.so): /lib/security/pam_listfile.so: cannot open shared object file: No such file or directory
May 1 14:12:09 HomeServer gdm-session-worker[1948]: PAM adding faulty module: /lib/security/pam_listfile.so
May 1 14:12:09 HomeServer gdm-session-worker[1948]: pam_succeed_if(gdm:auth): requirement "user ingroup nopasswdlogin" not met by user "deadrix"

This appears after each attempt to login at Gnome login screen.

I've reinstalled libpam-modules, but with no avail.

Please help to solve this.

May 2nd, 2011, 08:04 AM

May 5th, 2011, 03:51 AM
pam_tally --reset --user <username>
sudo pam-auth-update --force


May 5th, 2011, 04:32 AM
Btw, bump. I got those commands from another thread but they didn't work for me.

May 15th, 2011, 11:04 PM
I am experiencing the exact same thing.

I have used the above mentioned commands with no result.

Further I have tried to reinstall X and gdm, no luck!

I am currently looking into problems with pam. I will post results asap.

No solutions yet, but as far as i can see people have been having this sort of problem before.
So maybe the updater fails to install/update/configure/sanitize from 10.10 to 11.04 ?

Now I just need to figure out how to check for those errors?

May 25th, 2011, 02:28 PM
I had the same problem in Ubuntu 11.04 (32-bit). I found out that pam_listfile.so was not in /lib/security. I did a search and found it. Then I went to /etc/pam.d/gdm and changed the path from:




and that fixed the problem.

January 23rd, 2013, 09:32 PM
I ran into this in 12.04 32-bit. In my case, for some reason /lib/security was completely absent from the system, the folder didn't exist at all. My solution was to create it and copy all of the .so files from /lib/i386-linux-gnu/security into it.

January 24th, 2013, 07:50 PM
Old thread closed.