PDA

View Full Version : [SOLVED] 8.04 adept failure, now no network or sound



scurvybastard
May 1st, 2011, 04:29 AM
SOLVED: see post 3 below.

Long time linux user here but completely stumped on this one.

Got an 8.04 bawx as a quasi-media server at home with software RAID5 for some semblance of file security. It's been off for many moons as we moved back across country. It's been up and running fine for a while and I decided to upload some pictures onto it from my digital camera and noticed a boatload of stuff adept said was upgradeable (without upgrading to the next version).

It seemed to get through most of them before giving some manner of error - don't remember what - and one reboot later suddenly I can't get my wired networking or sound to work. knetworkmanager says there's no interfaces configured and no matter how much I try the built-in configuration utilities (K Menu > System Settings > Network) or manual configuration (/var/network/interfaces ; ifconfig ; the usual stuff) I can't raise a simple DHCP connection on either the built-in motherboard port (eth0) or the 1000 base T NIC (eth1). Everything else wired or wireless works perfectly with DHCP as did this machine until the adept nonsense.

Sound is also similarly busted, but that's another issue for another day.

Any way I can get the network up and running without resorting to a reinstall?

scurvybastard
May 3rd, 2011, 03:58 AM
(cricket noises)

Anyone? Bueller? Bueller?

Happy to help post up some diagnostic information if it would help, despite it being via sneakernet (see above question re: network problem).

scurvybastard
May 9th, 2011, 05:37 PM
Welp, problem now solved. Kinda.

Downloaded the i386 8.04 alternate CD & burned it; ran the cdupgrade program via sudo. Fortunately this also miserably failed due to still trying to use the network despite telling it I did not want to use the network (this is apparently a known bug yet remains unfixed). After several attempts, adept finally decided it had poorly installed several of the 9.04 packages & reinstalled them.

One reboot later I was subjected to the horrors of KDE4 but networking again worked properly so I could continue to apply upgrades all the way to the current release (11.04).

So if this happens to you, try downloading the alternate CD on your other computer & setting the busted adept pile of fail to upgrade from that several times and maybe it will realize it needs to fix the packages it broke when it core dumped the first time. Lesson learned: don't let your *buntu distribution go out of date, and if you do don't bother trying to update it. There's a derogatory comparison betwixt computers and a portion of the male anatomy which seems particularly apt now, but the margin is too small to contain it.

All my data is intact, so I'm good to install Fedora. Sorry, *buntu but we've got a saying in Illinois (I assume y'all have it in The Community too): 'Fool me once, shame on you. Fool me twice... won't get fooled again.'

Thanks for the thread views and I hope this helps someone.