View Full Version : [SOLVED] 2.6.35-27-generic-pae/build: No such file or directory

May 1st, 2011, 03:46 AM
I'm currently trying to add drivers for my new Linksys AE1000 wireless adapter, and found this tutorial (http://ubuntuforums.org/showpost.php?p=10163301&postcount=7). I'm at the 'make' step and when I try make, I get the error...

make -C tools
make[1]: Entering directory `/home/stephen/Downloads/2011_0427_RT3572_Linux_STA_v2.5.0.0.DPO/tools'
gcc -g bin2h.c -o bin2h
make[1]: Leaving directory `/home/stephen/Downloads/2011_0427_RT3572_Linux_STA_v2.5.0.0.DPO/tools'
cp -f os/linux/Makefile.6 /home/stephen/Downloads/2011_0427_RT3572_Linux_STA_v2.5.0.0.DPO/os/linux/Makefile
make -C /lib/modules/2.6.35-27-generic-pae/build SUBDIRS=/home/stephen/Downloads/2011_0427_RT3572_Linux_STA_v2.5.0.0.DPO/os/linux modules
make: *** /lib/modules/2.6.35-27-generic-pae/build: No such file or directory. Stop.
make: *** [LINUX] Error 2

So I checked the Makefile and found ..

LINUX_SRC = /lib/modules/$(shell uname -r)/build

uname -r returns


I ran
sudo apt-get install build-essential linux-headers-generic
uname is returning kernel 2.3.35-27, but there is no build folder there. However there IS a build directory for 2.6.38-8 which I'm guessing got created by the above command. So how do I fix this? Do I get the build stuff for an older kernel or do I use the newer kernel (which makes me wonder why it's not being used now anyway)? And how do I do either of those options?

May 1st, 2011, 04:33 AM
Okay I don't know why, but I restarted and it now works.

August 1st, 2011, 03:39 PM
Okay I don't know why, but I restarted and it now works.

A bit late, but maybe better than never? I had a similar problem - there was no build folder. You have to install the development version of the kernel - "kernel-devel".