View Full Version : [SOLVED] modprobe Error on Boot after Upgrade

April 29th, 2011, 04:54 PM
Good morning,

I did an in place upgrade of 10.10 to 11.04 last night. Upgrade seemed to proceed without problems.

Now on boot, the system hangs with the following error:

udevd-work[90]: '/sbin/modprobe -bv pci:v000010DEd000001D7sv00001179sd0000FF31bc03sc00 i00' unexpected exit with status 0x0009

Any advice would be appreciated. modprobe would seem to indicate a driver or kernel issue to me. I'm rather new to Linux, so my apologies ahead of time.


April 29th, 2011, 08:54 PM
I don't know the answer, but I downloaded 11.04 64-bit desktop .iso file and burned it to a CD. When I boot from the CD, I get the same error:

udev-work[90]: '/sbin/modprobe -bv pci:......'
unexpected exit with status 0x0009.

(Trying to upgrade via update manager just didn't work for me).

Lenovo Thinkpad T500, 4GB RAM.

April 30th, 2011, 12:13 AM
Appears to be a kernel issue for me.

If I allow it to boot automatically, it hangs. Upon restarting, I'm prompted with the grub selection list. If I choose previous versions, and load the version listed there, it seems to boot without problems.

The default selection is 2.6.38-8-generic, and the previous versions (the one that works) selection is 2.6.35-27-generic.


May 1st, 2011, 02:30 AM
I have same issue on my Lenovo W500, which has switchable video card (means two video card). I tried to set it to a single video card, it was working for a while and failed again.

any solution?

Jerry Zhang

May 1st, 2011, 03:54 AM
For me, it ended up being a problem with nouveau Nvidia nouveau driver. I'm not sure if it was updated for 11.04, but it caused my system to hang on boot. The old 10.10 kernel booted fine, and I was able to update the driver to the proprietary Nvidia driver. New 11.04 kernel boots fine now.