View Full Version : [ubuntu] 11.04 Unable to Shut down

April 29th, 2011, 12:32 PM
I upgraded to 11.04 (loving it so far) and just toying around with it a bit. However, whenever I try to shut it down or restart it takes an abnormally long time. Unfortunately I have not waited long enough for it to shut down properly (waited 10 mins) and it still hasn't turned off. Can someone help me?

Using a Dell Studio 1747 Laptop

April 30th, 2011, 06:52 AM
Same problem here. I'm using a Dell Studio and the system doesn't shutdown for a long time, and have waited for around the same time. Is this a bug or is it because Unity has slowed down my system?

April 30th, 2011, 10:28 AM
Well the problem got solved after a couple of forced shutdowns. I think it occurs because the update takes time to get stabilized with the system.

Edit:Sorry, the problem wasn't solved!! It still exists!!!

May 1st, 2011, 10:55 AM
For whatever reason, it seems to be working just fine now.

May 16th, 2011, 02:01 PM
I'm on a Asus EEtop 2203T pc, and i've the same problem

May 21st, 2011, 09:08 PM
I had (have) the same problem. I created a not so good work around as it is probably not safe to do what I did, but until a real solution gets posted, my work around keeps me from getting too frustrated. Here is what I did:

1. Create a script called K01shutdown.sh with the following contents:
poweroff --force
2. Copy the file to the /etc/rc0.d directory and make it executable.
3. Create a script called K01reboot.sh with the following contents:
reboot --force
4. Copy the file to the /etc/rc6.d directory and make it executable.

At least now I don't have to manually hold down the power down to turn off my computer. I look forward to the day a real solution gets posted.

August 10th, 2011, 08:09 AM
:D Try this....
in terminal type "sudo update grub" then follw the steps

Logout=> select user name=> (select sessn as 'xterminal') =>login=>type "sudo reboot"

this time evry thing ill be okey:)