PDA

View Full Version : 10.10 server on asus eb1007 no network device detected



KiltsRock
April 28th, 2011, 09:33 PM
I'm installing 10.10 server 64bit on an Asus EEEBox EB1007. The install does not detect any network adapters/cards/connections, so the network is left unconfigured. There is a network connection to the router and an IP assigned, but apt-get and other internet-facing utilities are not functioning.


has anyone tried this and found a solution?

( yes, this is my first ubuntu install )

Don DeGregori
May 3rd, 2011, 02:25 AM
Yes, I have same problem with same box, but installed regular 32 bit user version. I have a workaround, but involves a script. I can show it next time around. I, also can't get screensaver to work. On 2 other machines with 10.04 or 10.10 if works fine using same settings.
don

michaelb28
September 1st, 2011, 01:35 AM
I have 10.04 server installed on my eb1007. I think it was 32bit. Ethernet didn't work after setup, but all I had to do was make a proper entry for eth0 in /etc/network/interfaces and reboot.

apollothethird
September 1st, 2011, 01:52 AM
I'm installing 10.10 server 64bit on an Asus EEEBox EB1007. The install does not detect any network adapters/cards/connections, so the network is left unconfigured. There is a network connection to the router and an IP assigned, but apt-get and other internet-facing utilities are not functioning.


has anyone tried this and found a solution?

( yes, this is my first ubuntu install )

As this is your first install, I'm just curious why you didn't choose the latest version for your first install. It's my experience that issues that plagues one version is usually resolved in the next release.

You might test the live cd of the more recent release and see if your network adapter is discovered from the try option.

If this works the information might help someone else just starting out.

-- L. James

--
L. D. James
ljames@apollo3.com
www.apollo3.com/~ljames

michaelb28
September 1st, 2011, 05:17 PM
Try typing the following on the command line:

lsmod | grep jme

On my EB1007 I get the following output:

jme 31333 0
mii 5237 1 jme

If it is blank, you probably don't have the driver loaded for the Ethernet card.

Next type this:

cat /etc/network/interfaces

See if there is an entry for eth0.

If not, edit the file with pico or the text editor of your choice:

sudo pico /etc/network/interfaces

add these two lines to the end: (this assumes your router automatically assigns an IP address):

auto eth0
iface eth0 inet dhcp

Exit and save the file. Then reboot or type:

sudo ifup eth0

You might want to post the output of 'ifconfig eth0' if you still have problems.