View Full Version : [ubuntu] 10.10 To 11.04 Upgrade Stuck On "Setting up libgdu0 (2.32.1-0ubuntu4) ..." Cant Boot

April 28th, 2011, 07:59 PM

I just attempted to upgrade my Ubuntu 10.10 install to 11.04.

It failed and I can no longer boot. :(

This is an ASUS F3Sv laptop.

My screen locked up on the "Installing the upgrades" stage. With "About 4 minutes remaining" and at "Setting up libgdu0 (2.32.1-0ubuntu4) ...".

My Three Power Buttons Are Blinking.

So I hit my power button, but nothing happened. So I had to hold down power button to turn off.

Upon turning back on, right after BIOS, I see the expected GRUB boot menu.

I choose to boot into Ubuntu. I get a blinking Cursor for about half a second and then a solid Black Screen. About five seconds latter, two of my power buttons are blinking now. Center two.

I let it set there for half an hour. Nothing. Tried a few more reboots same thing. Recovery mode does this as well. Ouch!

"Previous Linux Versions" all result in two center power lights blinking and the right one solid. I tried all 6 versions plus their "recovery mode" and same thing. Bummer!

Looks like I get screwed again. Ugh! :-x

This is probably the 10th Ubuntu upgrade that has gone wrong for me over the years. Really getting sick of it!!

So now what to do?



April 28th, 2011, 08:16 PM
Sorry, I can't tell you how to fix it, but it looks like after 10 failed upgrades :shock: you're starting to realize why most of us use a separate /home partition & choose to do a fresh install as opposed to an upgrade.

See if you can find anything useful here...
I upgraded, and now I have this error... (http://ubuntuforums.org/showthread.php?t=1580857)

April 29th, 2011, 09:06 PM
edit: sorry for the rough/vague instructions.
edit2: Also it appears that I failed to read your post fully. Which recovery kernel are you trying to boot?

I had a similar problem, my laptop froze while installing some packages (unsure exactly where). I had no other option expect to reboot, which of course failed.

When you reboot and land on the GRUB screen select "Previous Kernel" and scroll down to the 4th kernel. This should be the recovery mode for the pre-upgrade kernel, press Enter, then press F10.

Your system will boot and provide you the option to use dpkg to repair broken packages.

After the packages are repaired you can reboot and you should hopefully be able to start using 11.04.

Let me know how it goes!

May 1st, 2011, 03:34 PM
I have just encountered the exact same problem on a Dell Precision 490 desktop - the first of three computers I need to upgrade.

The other two will now get fresh installs instead of upgrades.

I'm glad I burned an 11.04 install DVD before I started the upgrade. I am now running Ubuntu from this and will repartition drives to have a seperate /home partition before installing 11.04 from scratch.

May 13th, 2011, 10:40 PM
@jaredcurtis You are the man! :guitar:

It worked, back on home screen. Love you! :)

So it logged a ton of stuff on my screen as it went along. Where to though?

Would like to send my log files to ubuntu developers so this can be fixed.

I saw a bunch of "Setting up", "Installing", "Rebuilding", "Warnings" and "Obsoletes" notices flying by.

Even started downloading a bunch of "stuff". God knows what. Went flying bye. No chance to read.

At the end of it doing it's thing I saw:

"106 upgraded, 3 newly installed, 0 to remove and 0 not upgraded."

So 109 of them failed during the upgrade? Ouch!

Wow at least I am getting a 3 MB/s download rate. Thanks duke.edu !