View Full Version : [ubuntu] Grub2 set to 0 sec, how to bypass?

April 27th, 2011, 02:32 PM
I wanted to avoid the countdown in Grub, so I set it to 0 sec.

It worked all to well - it is 0 sec. Which means that I now boot directly into my default system, which is Windows.

How do I get back to the Grub menu, or just into Ubuntu so I can reset the countdown?

I have tried pressing all sorts of keys, including the left Shift key and Escape. Nothing works.

Do I really have to reinstall Grub??? If I do, can I use the version from my Ubuntu 10.10 installation disk, even if I am running 11.04? The reason is that I have no cd burner program in Windows, and no administrative rights to install one.

April 27th, 2011, 02:37 PM
boot from a Linux cd and reset your grub menu to the default.

April 27th, 2011, 03:27 PM
Open up a terminal and type this command:

sudo gedit /etc/default/grub

Then modify parameter GRUB_TIMEOUT:


Save and exit.

Finally type this command:

sudo update-grub

April 27th, 2011, 05:40 PM
Thanks, that worked. I had to search a little to find grub.cfg, but it was easy enough.

April 27th, 2011, 05:44 PM
dont tweak grub.cfg

sudo gedit /etc/default/grub

sudo update-grub