PDA

View Full Version : [gnome] Remove Last Gnome Panel In Natty



darrenm
April 27th, 2011, 11:03 AM
Hi there. In Maverick I could remove the last Gnome panel by editing gconf and removing gnome-panel from desktop > gnome > session > required_components.

I've just updated to Natty and doing this makes no difference. I assume Unity is doing it now, or maybe zeitgeist?

I've grep'd through .local and .config, and checked Startup Applications but it still loads gnome-panel every session.

Can anyone suggest anywhere to look?

Thanks.

KegHead
April 27th, 2011, 01:22 PM
Hi!

Will this help?

system...admin..login..choose default?

KegHead

Copper Bezel
April 27th, 2011, 03:20 PM
Right, are you using the Unity desktop or the Classic one? If it is the old Gnome-2-style one and the gconf key is being ignored for some reason, there are a couple of other tricks we can use (putting the panel on the widget layer or simply marking the panel binary as non-executable.) (Check your Startup Applications, too, as silly as that sounds.)

darrenm
April 28th, 2011, 10:13 AM
Hi!

Will this help?

system...admin..login..choose default?

KegHead

Sorry not in this case I don't think.


Right, are you using the Unity desktop or the Classic one? If it is the old Gnome-2-style one and the gconf key is being ignored for some reason, there are a couple of other tricks we can use (putting the panel on the widget layer or simply marking the panel binary as non-executable.) (Check your Startup Applications, too, as silly as that sounds.)

Using classic desktop. Unity causes issues with my dual-monitor setup and it's a bit pointless anyway for me when I want to remove all panels.

Can't see it in Startup Applications. Good shout on removing x from gnome-panel binary though. I'll try that thanks.

darrenm
April 28th, 2011, 10:23 AM
And it did work. Thanks!


sudo chmod -x /usr/bin/gnome-panel

Log out and back in. Sorted :)

Krytarik
April 28th, 2011, 10:24 AM
- Remove "panel" from the Gconf key "/desktop/gnome/session/required_components_list".

- If that doesn't help either, remove the content of "~/.config/gnome-session/saved-session".

Greetings.

Non Sek
May 4th, 2011, 02:19 PM
Hi,

I solved this problem based on this bug report:
https://bugs.launchpad.net/ubuntu/+source/gnome-session/+bug/774357

Go to usr/share/gnome-session

Edit as root the file "classic-gnome.session" and change the following line

From: Required-panel=gnome-panel
To: Required-panel=avant-window-navigator
(or your panel option)

I also "commented" the lines below, to avoid the test and the fallback.
## IsRunnableHelper=/usr/lib/nux/unity_support_test --compiz
## FallbackSessionsID=GNOME2d
## GNOME2d=2d-gnome

In the user login page, choose "Classic Ubuntu".

Then the last panel was gone. I believe this solution can be improved (it affect all users in the machine). So, comments will be appreciated.

Regards, NS.

kkjaergaard
September 2nd, 2011, 01:54 PM
...
Go to usr/share/gnome-session

Edit as root the file "classic-gnome.session" and change the following line

From: Required-panel=gnome-panel
To: Required-panel=avant-window-navigator
(or your panel option)
...

Is it possible to fully remove the last panel without root access and without affecting the other users of the system?