PDA

View Full Version : [xubuntu] 10.04 to 10.10 upgrade, libc6 failed, many errors, now kernel panic on reboot



RAKninja
April 26th, 2011, 01:54 AM
recently, i lost power during a storm. something about this corrupted something in either X, the savage drivers for x, or GDM. trying to fix this issue, i ended up booting into my install using vesa drivers and doing a distro update from 10.04 to 10.10.

i left the machine unattended, and when i returned, it had hung on updating libc6. there were no options to stop the upgrade at this point. the error message complained that xscreensaver was somehow preventing libc6 from updating.

this caused many other packages to fail upgrading. so many that eventually the upgrade terminated complaining "too many errors". at this point, i was still logged in. in an alternate terminal i tried stopping GDM. at this point i discovered sudo no longer worked.

i then tried logging onto one of the other tty's. i would type my username, hit enter, but instead of a password prompt, it returns to asking for the username.

i figure that perhaps it just needs a reboot. i then discover that none of my installed kernels will boot. they all complain they are unable to mount the root fs (or, on one, it claims that it got no answer while waiting and drops me to a initramfs prompt) and kernel panic.

i have a 9.10 live CD, with which i can boot to a GUI and make any needed changes to my installation. i do not have any blank disks with which to burn a 10.10 xubuntu install disk, nor does this dinosaur support USB boot.

how do i go about recovering my install back to 10.04, or complete the upgrade completely?

i remember one time doing a network install by downloading a network boot kernel image, perhaps i can do something similar? something to at least get be back to a working CLI, i can fix it from there. i just have no experience with grub/initramfs commands.

Edit:
after looking up more on lightweight linux distros, it seems the CPU on this machine (amd k6-2) is no longer supported in the 10.10 kernel. i'm going to go ahead, back up unreplacable data, and install antiX from iso on HDD.

byStanderone
April 26th, 2011, 02:44 AM
...hope you find something here:

https://ubuntugenius.wordpress.com/2010/05/24/fix-a-failed-initramfs-update-do-it-before-you-reboot/

RAKninja
April 26th, 2011, 05:04 AM
cant boot to a recovery boot of any prior kernels, so no nice from that link. thanks though.

xubuntu's a little heavy for this machine anyway. cpu runs 50% even on idle, so something lighter, like antiX is probably a better selection for me anyway.