View Full Version : [SOLVED] openoffice upgrade problem with 10.10

April 25th, 2011, 02:19 AM
Greetings, green user here. Synaptic is telling me I have broken packages. The broken filter lists the openoffice files. Trying to fix using synaptic or, using the terminal gives the same error:

Preparing to replace openoffice.org-core 1:3.2.1-7ubuntu1 (using .../openoffice.org-core_1%3a3.2.1-7ubuntu1.1_i386.deb) ...
Unpacking replacement openoffice.org-core ...
dpkg-deb (subprocess): failed to read on buffer copy for failed to write to pipe in copy: Input/output error
xz: (stdin): Unexpected end of input
dpkg-deb: subprocess <decompress> returned error exit status 1
dpkg: error processing /var/cache/apt/archives/openoffice.org-core_1%3a3.2.1-7ubuntu1.1_i386.deb (--unpack):
short read on buffer copy for backend dpkg-deb during `./usr/lib/openoffice/basis3.2/program/liblocaledata_en.so'
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

Suggestions? Until I get this resolved, i can't use the Software Center. Thanks

April 25th, 2011, 02:42 AM
Completely remove OpenOffice, and install LibreOffice.

OpenOffice is now owned by Oracle, who were wanting to make it commercial software, but most of the developers left and started The Document Foundation, and out of that came LibreOffice.

Basically, LO is the same as OO, but with a different name, and continued support.

LibreOffice can be found in Synaptic (at least it is here).

April 25th, 2011, 06:18 AM
It is no longer commercial software[1].


April 25th, 2011, 07:22 AM
If I type 'libreoffice' in Ubuntu Software Centre' then no item is shown.
Kindly suggest how to install it. Thanks.

April 25th, 2011, 08:36 AM
It is no longer commercial software

I never said it WAS commercial software, only that Oracle were seriously thinking about making it so, and that is why so many of the developers left after the take-over.

April 25th, 2011, 08:39 AM
If I type 'libreoffice' in Ubuntu Software Centre' then no item is shown.
Kindly suggest how to install it. Thanks.

I have it listed in Synaptic, but I honestly can't remember how I got it there. If you google it, you will find a way to install, but from all reports, it will be the default in 11.04 (which for us in Australia, is only 3 days away - 28 April).

April 25th, 2011, 09:05 AM
Go here (http://www.techdrivein.com/2011/01/remove-openoffice-and-install.html) to remove OO and install LO via PPA.

May 2nd, 2011, 01:19 AM
Solved with upgrade to 11.04 and installation of LibreOffice