View Full Version : [ubuntu] kerberos authentication problems after recent update

April 21st, 2011, 12:23 AM
Recently (4/19/2011) a security update was applied to the authentication software Kerberos. This update required a system reboot. However, after the reboot, my system could no longer authenticate against the key distribution center (KDC).

I've tried to debug this from the command line using the program kinit. The error I've received is:

"kinit: Cannot resolve network address for KDC in realm "MYREALM.NAME" while getting initial credentials"

I've looked around online and this usually indicates a DNS error. But if I haven't changed anything in my network set up, what else could be causing this problem beside the Kerberos update?

Has anyone else experience this problem? If so, were you able to fix it?

Thanks ahead of time.

April 21st, 2011, 04:02 PM
I solved the problem. It had absolutely nothing to do with the update. It had everything to do with our DNS service dropping the KDC address. I put in the IP address for the KDC and everything worked again.