PDA

View Full Version : [SOLVED] Postgre 8.3 on Ubuntu 10.04 LTS



irfans
April 20th, 2011, 02:26 AM
The default postgresql available on 10.04 is 8.4 but I need to have 8.3.
How do I install it?

Dutch70
April 20th, 2011, 03:03 AM
You should be able to download it and get the installation instructions from here...
Download (http://www.postgresql.org/)
Documentation (http://www.postgresql.org/docs/)

irfans
April 20th, 2011, 04:24 AM
Thanks Dutch but the postgresql official documentation does not really help.
Is there any way I can get the Postgresql 8.3 in the 10.04 repository?

Dutch70
April 20th, 2011, 05:21 AM
Not that I know of, but that's not really saying much. :P

I believe if you can find a DEB package, it will be very easy to install with software center. There are some in the following link, but they don't seem to go back to 8.3.
http://www.openscg.org/se/postgresql/archive-packages.jsp (http://www.openscg.org/se/postgresql/archive-packages.jsp)

irfans
April 21st, 2011, 01:41 AM
I could get the bin file(postgresql-8.3.15-1-linux-x64.bin) for postgre 8.3.
To install I ran the followong commands,
chmod a+x binfile
sudo ./binfile

This gives an error,
./postgresql-8.3.15-1-linux-x64.bin: 3: Syntax error: ")" unexpected

Whats possibly going wrong ?

irfans
April 21st, 2011, 03:59 AM
I was finally able to install postgresql 8.3 following the below steps,

You should be able to use any of the listed mirrors by adding a line to your /etc/apt/sources.list like this:
deb http://security.ubuntu.com/ubuntu hardy-security main

Then using the Synaptic manager apply the packages for 8.3..
Finally run apt-get install postgresql-8.3 :D

Dutch70
April 21st, 2011, 04:25 AM
Nice! Thanks for posting your solution irfans. :)

People will be more likely to find & use it if you mark it [Solved] with "Thread Tools" at the top of the page.