View Full Version : Genius F610 tablet issue

April 19th, 2011, 04:31 PM
I was reading a lot of thread about this subject... My Tablet works, and it's recognized by ubuntu... but with very weird and annoying issues... Ubuntu don't recognize the "over tablet" movement... only when I put the pencil on the tablet, and it acts like a left click, so when I drag the pointer draws the selection box.
Looks like Ubuntu don't see when I move the pen without touching the tablet.. In windows works perfectly (but i want to leave windows!!)

What can be the problem... I've tried all things in the threads... also there is a blog post about this, and talks about "sudo /etc/rc.something start" well, that command says that there is no UDev tablet... so something is not working properly i guess...

Thanks a lot in advance!

April 19th, 2011, 06:43 PM
Hi josempans,

You don't say which release of Ubuntu you are using.

Anyway I think you have a rebranded Waltop tablet. Enter lsusb or xinput list in a terminal to check.

If so see the Waltop HOW TO (http://ubuntuforums.org/showthread.php?t=1595648).

My guess is your current problems are because the tablet is on the evdev X driver.

April 19th, 2011, 10:09 PM
oh, :P.. I forgot to mention the version... Ubuntu 10.04. I'll do that and let you know... thanks!

April 19th, 2011, 10:51 PM
ok... I'm near to quit, :P... too many information and i don't know what to do
this is my xinput info:

⎡ Virtual core pointer id=2 [master pointer (3)]
⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
⎜ ↳ WALTOP International Corp. Slim Tablet id=8 [slave pointer (2)]
⎜ ↳ ImPS/2 Generic Wheel Mouse id=10 [slave pointer (2)]
⎜ ↳ Macintosh mouse button emulation id=11 [slave pointer (2)]
⎣ Virtual core keyboard id=3 [master keyboard (2)]
↳ Virtual core XTEST keyboard id=5 [slave keyboard (3)]
↳ Power Button id=6 [slave keyboard (3)]
↳ Power Button id=7 [slave keyboard (3)]
↳ AT Translated Set 2 keyboard id=9 [slave keyboard (3)]

The tablet buttons don't work well, there is no "translation" over the tablet, sometimes yes, sometimes no... sometimes the pen tip acts well, and sometimes work only like left click.
I've tried uninstalling the wizardpen driver to have no conflicts with wacom... I don't know if uninstalling wacom drivers and re-installing wizardpen will work. When I want to try to uninstall the wacom ubuntu shows me that it will uninstall another package too (xorg-*-all) is this ok?

April 19th, 2011, 11:35 PM
OMG is working!!... thanks!!!

For anyone with the problem: for Genius F610 tablet in a Ubuntu 10.04
Just follow this:


Thanks FAVUX!!