View Full Version : [xubuntu] lenovo trackpoint stoped working after upgrade to lucid

April 18th, 2011, 12:00 PM
I mean the wheeling action which was performed by holding down the middle button and moving the trackpoint is not working anymore. Has anybody had a similar problem?

April 18th, 2011, 12:06 PM
But in my experience, the trackpoint/middle button scroll does not work "out of the box".

I have to change settings upon a fresh install to get it to work.

This is the page that showed me how to do what I needed.
the section I used is called Configuration using the X server (xorg.conf)

Here is a link specifically for Lucid/10.04

Hope you get it going. :)
Good luck.

Edit: AND while looking for your link...
I came across one for me..[for 10.10] http://psung.blogspot.com/2010/09/thinkpad-trackpoint-scrolling-in-ubuntu.html
and it makes it soo much easier than what i had to do! :lol:
Super easy.

last edit: I'm assuming you could use the same instructions for 10.10 on 10.04
I don't see why not.
It's really only installing GPointing settings tool and checking off a few things.
Might be worth a shot.

April 18th, 2011, 04:26 PM
I installed gpointing-device-settings and followed the instructions in the link you supplied and now it works. Thanks a lot!

April 18th, 2011, 04:40 PM
No problem! Glad it worked!

I have read a few places that some people have issues with it , as it stops working once they resume from suspend, but I have yet to see that happen.
It works after suspend, hibernate, or fresh boot.
Hope it works the same way for you! lol
There are ways to fix it tho if it happens. :)

April 18th, 2011, 05:11 PM
Good, please mark the thread 'solved' in 'thread tools'.

April 20th, 2011, 12:04 PM
Well, I encountered a problem. It stopped working after a reboot. When I run the program, the appropriate checkboxes are checked. I don't know what to do.

April 20th, 2011, 12:43 PM
I'll try to help later when I get back to my Thinkpad.