PDA

View Full Version : [SOLVED] Dell e6510 SD reader nonresponsive



windfix
April 13th, 2011, 08:37 AM
Any ideas?

I had the e6500, SD card reader worked fine. On the e6510, nothing happens when I insert a card - tried several. Running 10.10 64-bit

lspci lists "04:00.1 SD Host controller: Ricoh Co Ltd Device e822 (rev 03)", not sure if this is the card reader though

ifreecarve
April 14th, 2011, 04:43 PM
This is a known bug, see this page: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/730820

matt-fender
April 14th, 2011, 04:46 PM
Can you perform a fresh boot

then save output of


dmesg

then insert SD card and save output of


dmesg

again.

Also, have you tried inserting the SD card before switching the laptop on, does it mount?

Regards.

windfix
April 14th, 2011, 08:35 PM
Thanks for pointing out the bug report. Sounds like Natty will fix this, so I will just wait a few weeks for the upgrade. Will check the dmesg output this evening, no card available at the moment

windfix
April 14th, 2011, 08:36 PM
Y, doesn't work even if the card is inserted prior

windfix
April 15th, 2011, 10:14 PM
@matt-fendr, re: dmesg

Here is prior: http://dl.dropbox.com/u/2924774/dmesg%20prior

Here is after: http://dl.dropbox.com/u/2924774/dmesg%20after

matt-fender
April 17th, 2011, 02:19 AM
Sorry for the late post

found this in your dmesg


[ 354.836603] mmc0: error -110 whilst initialising SD cardI'll see if i can pull up any old threads

EDIT:

Disabling ADMA gets around this issue.

I've attached a modprobe configuration file which does this. After
creating this file into /etc/modprobe.d and reloading the sdhci kernel
modules (rmmod sdhci_pci and sdhci, then modprobe sdhci_pci), I can use
the card reader on my E6510.

** Attachment added: "Modprobe configuration file to disable ADMA when loading shdci module."

Link to modified modprobe config file (http://launchpadlibrarian.net/53259856/latitude-e6510-cardreader.conf)

windfix
April 17th, 2011, 02:38 AM
Thanks for the fix. Can you guide me a bit though? I only half understand how to do this. What should the created filename be, "sdhci.conf"?

And re: reloading sdhci kernel, are these the bash commands?

rmmod sdhci_pci
rmmod sdhci
modprobe sdhci_pci

matt-fender
April 17th, 2011, 02:48 AM
Open a terminal and paste


sudo gedit /etc/modprobe.d/sdhci-pci.confthen paste this into the new empty config file


options sdhci debug_quirks=0x40
save and close it.

now enter these in a terminal one at a time


/etc/modprobe.d# rmmod sdhci-pci

/etc/modprobe.d# rmmod sdhci
/etc/modprobe.d# modprobe sdhci-pcitry out your SD card

windfix
April 17th, 2011, 03:20 AM
sorry to be a pain, but after creating that file, which I can verify contains " options sdhci debug_quirks=0x40", I get this message after each of the next three commands:

"bash: /etc/modprobe.d#: No such file or directory"

Should I omit the "/etc/modprobe.d#" portion of those lines and execute them as sudo?

matt-fender
April 17th, 2011, 03:22 AM
Ooops sorry, the commands are


rmmod sdhci_pci


rmmod sdhci


modprobe sdhci_pci

windfix
April 17th, 2011, 03:39 AM
Thanks. It took those commands when executed as sudo. I rebooted... still have the error under dmseg: "mmc0: error -110 whilst initialising SD card"

Appreciate the effort though, thanks. Hopefully this bug will get squashed later.

matt-fender
April 17th, 2011, 03:42 AM
Can you post the output of


uname -a

according to the launchpad bug page, this issue was fixed with kernel 2.6.35-28.50

windfix
April 17th, 2011, 03:51 AM
Here's the output:

Linux paul-Latitude-E6510 2.6.35-28-generic #50-Ubuntu SMP Fri Mar 18 18:42:20 UTC 2011 x86_64 GNU/Linux

I just got a kernel update yesterday, via update manager. Odd

windfix
April 25th, 2011, 07:26 PM
Here's the output:

Linux paul-Latitude-E6510 2.6.35-28-generic #50-Ubuntu SMP Fri Mar 18 18:42:20 UTC 2011 x86_64 GNU/Linux

I just got a kernel update yesterday, via update manager. Odd


Well, the issue is suddenly resolved. Maybe it was a subsequent update to the kernel, but my SD reader is back in business. Hurrah!

xsmurfster
June 23rd, 2011, 06:00 PM
I signed up to say thanks and to say that this fixed the Ricoh SD card on my Lenovo X220!

xsmurfster
June 24th, 2011, 07:57 PM
However, the sd card reader breaks again after hibernate and I need to rmmod/modprobe again for it to work.

hawthorne62
June 26th, 2011, 04:04 AM
I'm having the same issue with a non-responsive external card reader. (Other USB devices work normally.) My kernel is 2.6.32.32 generic, and no updates have come up through Update Manager.

It shows up in lsusb, so it looks like having a newer kernel might fix the issue, but I'm hesitant to go down that road if I don't have to.

This forum and the following links are some of the ideas I've found:

http://forums.linuxmint.com/viewtopic.php?f=42&t=40185&hilit=kernel
http://community.linuxmint.com/tutorial/view/309#confirm

Thoughts?