PDA

View Full Version : [SOLVED] Asus G73JW-A1: Suspend/Hibernate Issues



Aang_Aero
April 13th, 2011, 01:53 AM
System Info:



Asus G73JW-A1
Ubuntu 10.04.02 - 64-bit
Kernel - Linux 2.6.32-31-generic (x86_64)
BIOS Setting: USB3.0 Controller Switch = EHCI Mode

Issue:

System will not Suspend or Hibernate.

Upon issuing the command to Suspend, the screen goes blank (looks like suspend it is working) but then just pops up the box asking me for my username and password.

Upon issuing the command to Hibernate, the screen goes blank, and the screen displays this:

[ 1211.867583] pm_op(): usb_dev_freeze+0x0/0x20 returns -2
[ 1211.867588] PM: Device usb3 failed to freeze: error -2(I have NO usb devices attached)

Once again the username and password pop-up box is displayed.


Question:

Anyone else experiencing this issue (on there Asus G73JW-A1 or other laptop) ?

Anyone have any tips on how to solve this?


Thanks in advance for any tips you can provide :)


Update (04/17/2011):

In my BIOS, I changed USB3.0 Controller Switch to XHCI Mode then tried this:

1. Create the file below:

gksudo gedit /etc/pm/config.d/unload_module2. Added this to the first line, save file, and reset:

SUSPEND_MODULES="xhci"After performing the steps above I could Suspend, but the computer would not wake up. I had to power off and restart :( But I got half-way there :/

Also, I set USB3.0 Controller Switch back to EHCI Mode, and tried this setting for the unload_module file above:

SUSPEND_MODULES="ehci"However, this had no affect :(

Aang_Aero
April 22nd, 2011, 08:37 AM
Found a solution that worked, I can now hybernate/suspend! :D

Click on the link to the post below.

Follow the steps listed in post #7 & #8

http://ubuntuforums.org/showthread.php?t=1444822