View Full Version : [ubuntu] update failure in 10.10 has messed up ubuntu

April 8th, 2011, 10:31 PM
Hi. Today, I installed Ubuntu 10.10 on a desktop computer, using a working live disk. While installing, i opted not to install updates. I restarted when installation was complete and ubuntu was working fine. But when I tried to do an update, it got stuck at

Running post-installation trigger man-dbThen the screen went really dark and ubuntu completely froze up. i switched off the computer, switched it on again, and got this error:

uncompression error

--System halted

I restarted again, and the GRUB menu appeared (i think that's what it's called). I selected Linux 2.6.35-22-generic (recovery) and got another error when the computer was "Loading initial ramdisk". I restarted AGAIN, this time selecting Linux 2.6.35-22-generic from the GRUB. But this just put the computer into a loop of rebooting and showing the GRUB menu. I tried Linux 2.6.35-22-generic again, this time getting this:

error: couldn't read file

This is a real problem for me, as i don't have very much experience with ubuntu. Sorry the post is so long. Thanks, chaozuper.

April 8th, 2011, 11:37 PM
The screen turning dark grey is not an error. It only means that there is a heavy work load. When you see it again, just give the machine some time.

Best is to install all updates as soon as possible, that is during installation.

April 9th, 2011, 02:36 PM
well, i switched the computer back on this morning and ubuntu loaded up! the update manager told me i should do a partial upgrade, so i did that but the screen went completely black with only my cursor left whilst upgrading (not the same as before). i rebooted and now i'm getting this error again:

uncompression error

--System haltedand also a new one:

error: reloc offset is out of the segmentany more help would be greatly appreciated

EDIT: just tried reinstalling 10.10 using live disk and got this error

Input/output error during read on /dev/sda

April 9th, 2011, 05:24 PM
Partial upgrades are dangerous:

The input/output error could (among other things) be a sign of a hard drive going bad. You could try wiping it completely with Killdisk and see if it still reports errors.

Killdisk has an ISO which burns to a CD just like Ubuntu.

April 9th, 2011, 05:28 PM
so i could just run killdisk on the computer, then try installing ubuntu? or would i have to do extra stuff to get it to work?

April 9th, 2011, 07:27 PM
Yes, just run Killdisk and install. Since the machine seems to have some trouble with 10.10, I would try 10.04.2, which is supported two years from now.

April 9th, 2011, 08:02 PM
ok, i tried killdisk, but it just stays at 0%. i'm using all the default options.

EDIT: could it possibly be that my hard drive has failed?

April 10th, 2011, 02:07 PM
Yes, it sounds like a hard drive going bad. I assume that you have not changed cable connections and the like.

There are many ideas on the web about how to bring a dying hard drive back to life, but it is not worth the while. A new (or used) hard drive is so cheap that there is no point in messing with the old one.