PDA

View Full Version : [ubuntu] cannot ls



dalek-kaan
April 8th, 2011, 10:31 PM
ls: error while loading shared libraries: /lib/libacl.so.1: invalid ELF header

I get this when i open the terminal in UBUNTU 10.10
i can still type but it's just above samuel@Klaxon:~$

s: error while loading shared libraries: /lib/libacl.so.1: invalid ELF header
samuel@Klaxon:~$

this just started yesterday i've been running this computer for a couple of months with no problems
and then suddenly that appears and the computer wont play sound

if anyone knows what is going on i would appreciate it very much. thank you

Temüjin
April 9th, 2011, 01:37 AM
Possible file corruption. Re-install problematic package/file:

sudo apt-get install --reinstall libacl1
fsck of your / is also a good idea.

cjhabs
April 9th, 2011, 02:15 AM
check that you are picking up the correct ls command.


which ls