View Full Version : [ubuntu] 11.04 dmraid does not activate ufter upgrade

April 2nd, 2011, 05:18 PM
After uprading to 11.04 b1 i cannot activate my softraid. It still works if i boot 10.10 live CD

root@bisley:/home/goblin# dmraid -ay
RAID set "pdc_dhifadccdc" was not activated
root@bisley:/home/goblin# dmraid -s
*** Set
name : pdc_dhifadccdc
size : 8201755392
stride : 128
type : stripe
status : ok
subsets: 0
devs : 2
spares : 0
root@bisley:/home/goblin# dmraid -r
/dev/sdc: pdc, "pdc_dhifadccdc", stripe, ok, 4100877696 sectors, data@ 0
/dev/sdb: pdc, "pdc_dhifadccdc", stripe, ok, 4100877696 sectors, data@ 0

root@bisley:/home/goblin# dmraid -V
dmraid version: 1.0.0.rc16 (2009.09.16) shared
dmraid library version: 1.0.0.rc16 (2009.09.16)
device-mapper version: 4.19.1

any input would be helpfull.:confused:

April 2nd, 2011, 05:30 PM
I've reported it as a bug but there is no sign yet that anything will be done about it.

I believe that what you will find is that dmraid is uninstalled in the upgrade. I resurrected mine from a live cd by mounting the partition I installed to to /mnt and using chroot to install dmraid. Everything works fine now but that shouldn't have been necessary.

April 20th, 2011, 05:34 PM
I can't believe this is happening again. I had exactly the same problem when upgrading to 10.10 and now it seems it does it when upgrading to 11.04.

There is no way a normal user would be able to sort this out. This is the kind of thing that gets a distro a bad rep.

Come on Ubuntu, sort it out!

April 22nd, 2011, 04:36 PM
Come on Ubuntu, sort it out!

I couldn't agree more. At least the 11.04 b2 seems to install properly to a raid - so things are fine for the time being!

April 24th, 2011, 05:44 AM
I'm having the same problem with an upgrade from 10.10 I performed today ( 4/23).

dmraid -r
/dev/sdd: pdc, "pdc_igjghfjc", mirror, ok, 8201865344 sectors, data@ 0
/dev/sdc: pdc, "pdc_igjghfjc", mirror, ok, 8201865344 sectors, data@ 0

dmraid -s -s
*** Set
name : pdc_igjghfjc
size : 8201865344
stride : 128
type : mirror
status : ok
subsets: 0
devs : 2
spares : 0

dmraid -a yes
RAID set "pdc_igjghfjc" was not activated

My old UUID for the disk disappeared in the upgrade :( any ideas or bug numbers I can track?

- thanks

April 26th, 2011, 06:35 AM
I'm in the same boat, except pretty much everything (no sound, didn't have permission to mount disks) got fubar'd by the upgrade. I'm forced to backup everything and reinstall.

Perhaps there is something we have in common, I've noticed that we all have Promise fakeRAID controllers (mine via AMD). The changelog lists some changes that were made to the Promise code, so perhaps something was unintentionally messed up.


Edit: For what it's worth, here's the output of dmraid

$ sudo dmraid -s
*** Set
name : pdc_bhgbgdbai
size : 8201755392
stride : 128
type : stripe
status : ok
subsets: 0
devs : 2
spares : 0

$ sudo dmraid -r
/dev/sdb: pdc, "pdc_bhgbgdbai", stripe, ok, 4100877696 sectors, data@ 0
/dev/sda: pdc, "pdc_bhgbgdbai", stripe, ok, 4100877696 sectors, data@ 0

April 26th, 2011, 08:30 PM
Ok, so I booted up a 10.10 livecd, no problems activating the set so the problem is 100% either dmraid's or the kernels.

I'm going to bite the bullet and back everything up and switch to software raid.

April 27th, 2011, 08:16 PM
The problem as you stated it occurred because dmraid wasn't installed. The problem seem to be fixed with updates. Meanwhile I have worked around it by a chroot install of dmraid to a new unresposive Ubuntu install.

The problem shouldn't occur with an install of the latest 11.04 image.

April 29th, 2011, 03:09 AM
For anyone who's curious: https://bugs.launchpad.net/ubuntu/+source/dmraid/+bug/770600

April 29th, 2011, 07:00 AM
Booted up with 11.04 final release CD today and still no joy. Was hoping they would have it sorted for the final release. I am very disappointed.

Running suse 11.4 till a practical fix has been made. Not terribly fond of suse :(

April 29th, 2011, 07:41 AM
Tried starting with 32 bit version and same problem. Seems the dmraid version and device mapper is exactly the same as the beta's.

Suse uses:
dmraid version: 1.0.0.rc16-3 (2010.01.12)
dmraid library version: 1.0.0.rc16-3 (2010.01.12)
device-mapper version: 4.18.0

works perfectly under suse but my audio is now choppy. I need a drink...

April 29th, 2011, 10:29 PM
I was dreading that this would happen once I upgrade...
I'm going to attempt to do that today. Not sure if its the same problem...
But last time(10.10)...to fix dmraid not activating (promise raid 0)...I had to modify dmraid script in /usr/share/initramfs-tools/scripts/local-top/dmraid


# local-top script for dmraid.


case $1 in
# get pre-requisites
exit 0

# Activate any dmraid arrays that were not identified by udev and vol_id.

sleep 2
/sbin/dmraid -i -ay

#if devices=$(dmraid -r -c); then
# for dev in $devices; do
# dmraid-activate $dev
# done

make sure all the modules and hooks are also present for dmraid

And then rebuild using:
sudo update-initramfs -k -u all

That fixed it for me...though I haven't tried on 11.04 just yet...

May 22nd, 2011, 07:27 AM
From rexbron's link i found this ppa. ppa: psusi/ppa

Fixes problem with raid 0 on promice fast track. This is still not fixed in ubuntu 11.04 updates but thanks to Phillip Susi i get to run ubuntu again. ):P