View Full Version : [ubuntu] 10.04 64-bit / nVidia GeForce 8400GS

March 28th, 2011, 08:00 PM
I'm having a problem getting 64-bit Ubuntu 10.04 working with my PCI Express nVidia GeForce 8400GS video card (badged as an Asus, in case that makes any difference). Here's what I've done so far:

1. Tried a default installation but got a blank white screen. Fixed this by hitting F6 and choosing nomodeset before proceeding with the install. This allowed me to complete the installation.

2. On initial boot after installation, I got the white screen again. I got past this problem by using the Shift key to get to the grub menu, then pressing e to edit the grub entry, and replacing the quiet and splash options with nomodeset. This allowed me to boot with minimal video.

3. Once successfully logged on to Ubuntu, I tried installing the latest driver (using the Gnome menus). Having installed this, I failed to get any video at all after rebooting, (monitor went into sleep mode). Booted recovery mode to recover from this.

4. Tried the version 173 driver. Same problem as step 3 above.

5. Tried downloading the latest 64-bit Linux driver for the 8400GS from nVidia's web site. First, removed all nVidia drivers (sudo apt-get --purge remove nvidia-*), then rebooted and ran the nVidia installation script. Result: same problem as step 3 above.

6. Experimented with blacklisting nVidia drivers. Blacklisted the following: vga16fb, nouveau, rivafb, nvidiafb, and rivatv. Uninstalled and reinstalled driver. So far, I'm still getting the same problem as in Step 3 above.

Has anyone successfully got this card working with 10.04? I've found messages in various places from people who say they have, but I've not found any suggestions to do anything other than the things I've tried. Does anyone have any suggestions?

Frogs Hair
March 28th, 2011, 08:29 PM
I have been using the same card on three different versions of Ubuntu for just over a year . I use the Nvidia current driver installed from the jockey . I installed the 173 driver by mistake when installing 10.10 and everything was jerky and in slow motion . it works fine with Compiz using the 260.19 driver.

March 28th, 2011, 11:26 PM
Thanks for the info. I see you're running an earlier version of the 260.19 nVidia driver (260.19.06, whereas the version I have is 260.19.44). I wonder if that could be my problem.

Maybe I should just get a new video card rather than spend ages trying to get this one working.

Frogs Hair
March 29th, 2011, 02:48 AM
There are others using the same card . If you can , test the card on another computer . An 8400GS is about $30.00 right now , for twice the money you can get twice the card .