View Full Version : [SOLVED] Thunar and mimetypes, spec. .doc

Copper Bezel
March 26th, 2011, 01:27 AM
Hello all.

I love Thunar - it's the koi pond to Nautilus' English garden - but it's giving me a bit of trouble with text document mimetypes, or more properly extensions, since Thunar looks at extensions first. It recognizes .xml and opens gedit, it recognizes .docx and .odt and opens OpenOffice, etc., but if I right-click a .doc file and select Properties, it tells me that I'm looking at a Plain Text Document. If I select OpenOffice as the default application, then all Plain Text Documents load in OpenOffice, which is a bit of a pain in the *** if I'm loading a system configuration file or a plaintext shopping list made up in GEdit.

For compatibility reasons at school, I have to use .doc for certain things, and I have a lot of old files saved in .doc format. The obvious solution would be to use .odt whenever possible and leave the Plain Text Document type associated with GEdit, but I don't want to have to right-click and select OpenOffice or drag files to my dock every time I want to open a .doc file. Is there any way to get Thunar to distinguish these extensions from one another?

Thanks for any help.

March 26th, 2011, 02:10 AM
Hi Copper Bezel,

I just yet tried to reproduce the described behaviour, but it works as expected at my system.

1.) I created a new "Empty File", appended ".doc" to its name, and it gets recognized by both Nautilus and Thunar as "Word document", automatically associated with "OpenOffice.org Word Processor".

2.) The same is true for some old real .doc-files.

Copper Bezel
March 26th, 2011, 02:58 AM
Well ****. What did I screw up? Oy ... I guess I'll live with it, then. = (

Thanks. = )

March 26th, 2011, 03:03 AM
But Nautilus recognizes the mimetype of .doc-files correctly?

Copper Bezel
March 26th, 2011, 03:24 AM
Yeah, but it's a completely separate system. Nautilus ignores extensions entirely, using only mimetype information, and it respects and sets Gnome's preferred applications instead of storing its own. If both Thunar and Nautilus were having problems with this, I would simply have to accept it as the will of the gods. = )

March 26th, 2011, 04:20 AM
Could that be the solution? Do you have KDE installed?:

Copper Bezel
March 27th, 2011, 04:53 AM
Yeah, I have parts of KDE installed. That fixed it - thanks! = )

March 27th, 2011, 05:12 AM
Yeah, I have parts of KDE installed. That fixed it - thanks! = )

Then please mark this thread as "solved". LOL:D

Copper Bezel
March 27th, 2011, 05:52 AM
Oh, right. :redface: