PDA

View Full Version : [ubuntu] gnome-terminal geometry does not work?



Kleenux
March 10th, 2011, 05:08 AM
I did a search. But I'm not sure about the latest status - posts reporting a problem are pretty old.

So, is there a problem with gnome-terminal --geometry?

For instance

gnome-terminal --geometry=100x50works fine.
but

gnome-terminal --geometry=100x50-0+0does not work.

The '-0+0' is either ignored or wrongly processed.
It should put the window sticked to the right side, and to the top.
But, instead, the window appears to be positioned randomly on the screen (while the size is correct, 100x50). :confused:

hictio
March 10th, 2011, 06:03 AM
It works A Ok for me...
Try this:



gnome-terminal --geometry 100x50-0+0


Also, do you have Desktop Effects enabled? Perhaps one of the widgets is forcing an intelligent window placement?

Krytarik
March 10th, 2011, 06:15 AM
I tried it with your commands and it works as expected.

If you are using Compiz, you could also use its "Place Windows" plugin for that:
"System -> Preferences -> CompizConfig Settings Manager -> Window Management -> Place Windows".

Of course this would mean that the terminal is always opened at the specified position.

Kleenux
March 10th, 2011, 11:42 AM
Thanks for your answers.

I see that compiz is installed - by default since I didn't force it myself (Ubuntu 10.10).

The Visual Effects are set to Normal.

Are you on 10.10 maverick?

hictio
March 10th, 2011, 05:32 PM
Thanks for your answers.

I see that compiz is installed - by default since I didn't force it myself (Ubuntu 10.10).

The Visual Effects are set to Normal.

Are you on 10.10 maverick?

Not me, plain vanilla Lucid Lynx 32 bits.

Krytarik
March 10th, 2011, 07:27 PM
The Visual Effects are set to Normal.

Are you on 10.10 maverick?
Me neither, see left.

Then just put it the Compiz way.

Kleenux
March 11th, 2011, 02:54 AM
It works on my other Ubuntu 10.04.1...

So I'm guessing there is a bug in gnome-terminal from 10.10.

I'm looking at a simple, works anywhere solution, so compiz is not an option.

gnome-terminal --geometry=100x50-0+0should just work...

This is probably a bug.

cipherboy_loc
March 11th, 2011, 03:16 AM
Running the command gets a window of the correct size, but at the right part of the screen for me. Currently, I am running Ubuntu 10.10 + Fluxbox (which might be my issue). If I log back into gnome sometime today, I will let you know if it works any better.


Cipherboy

mcduck
March 11th, 2011, 07:41 AM
Thanks for your answers.

I see that compiz is installed - by default since I didn't force it myself (Ubuntu 10.10).

The Visual Effects are set to Normal.

Are you on 10.10 maverick?

Then you are using Compiz. :)

Just install CompizConfig Settings Manager and you can configure the geometry options there. The settings you need are in the "Place Windows"-plugin's options, under the "Fixed Window Placement"-tab.

(Visual Effects set to "None" uses Metacity as window manager, "Normal" and "Extra" both use Compiz)