PDA

View Full Version : [ubuntu] STORE NOT WORKING error 35: gnutls_handshake()



vgokulakrishnan
March 8th, 2011, 08:01 AM
Hello.. I'm a newbie in UEC Cloud..
I ve a serious problem with UEC Store.
From the start it's showin Error, "Error 35: gnutls_handshake() failed: A TLS packet with unexpected length was received."
I ve tried everything, please consider this brief story of my UEC
"I installed UEC Cloud by CDInstall from help.ubuntu.com/community/uec/cdinstall .. And fixed some issues by commands including euca-desc-availablty-zones.
I dint do any other settings or changes. All working fine except UEC Store.
[ CC communicating with NC, all components are Running, Tried Image Store Purging too.. Nothing made store good.. always showin error 35..]

Tried all changes, but succeeded in nowhere making this STORE workable.
This is ma short story of My UEC.."


Awaiting for ur very valuable replies guys..
Thanx in advance

kim0
March 8th, 2011, 01:10 PM
Are you trying to download images from the image store ?

If so, I think UEC is trying to connect over https and getting some random gibbersh data back. Do you have some proxy or restricted Internet access somehow? If so that might be blocking UEC from downloading what it needs

vgokulakrishnan
March 9th, 2011, 03:03 AM
hi, my servers too, are under proxy network, and all clients too under
firewall.. can you help me out how to setup a store under proxy..
Isn't there a way for that..
I tried purging Image Store didnt help :(
If we upload a image will it work, showin atleast my image..
Can we use any other software for uploading as an instance, without uploading an os..
Thanx again..

kim0
March 9th, 2011, 10:20 AM
You might wanna publish an image "manually" without using the web store
Check out these instructions
https://help.ubuntu.com/community/UEC/BundlingImages

Or just ask your IT people to give an exception to you and allow you unrestricted internet access

vgokulakrishnan
March 9th, 2011, 01:00 PM
This manual uploadin/unrestricted internet, should be done in CC server isn't it..
Let me say my organization infra, All machines are under firewall/proxy, and only the Org-Server is out of it..
I asked for Unrestricted internet in my machine..
I'm gona try after gettin it, whether it's workin properly in Org-Server.
:)
Thanks for your help, I may need more..
I ll let you know if its working good.. :)

vgokulakrishnan
March 10th, 2011, 01:28 PM
"uec-publish-tarball" not working..
It replies "Unable to run euca-describe-images. Is euca2ools environment set up?"
But I ve installed euca2ools and i think its working..
What may have gone wrong..
Waiting for your response

kim0
March 11th, 2011, 12:23 PM
Hi, check step-5 on https://help.ubuntu.com/community/UEC/CDInstall
to configure your eucarc file with credentials

vgokulakrishnan
March 14th, 2011, 09:56 AM
my port no for WebUI is 8443
but its set 8773 in eucarc file u said..
U know actually, I did mentioned step5 before itself..

kim0
March 15th, 2011, 09:07 AM
Just confirming that yes, 8773 is the port used by euca-xxx commands. The "human" web interface is on port 8443 however