PDA

View Full Version : [xubuntu] rip cd tracks with abcde but ogg quality always shows 112kbs



thaitang
March 8th, 2011, 05:36 AM
I have used abcde with lots of success in the past and I always grab the a config file off the net (I think andrew's web page or something).

Anyways, I went to rip a few cd's to OGG today and my quality setting is: OGGENCOPTS='-q 6'
but when I play the ogg's (using audacious or gnome player) the kbs always shows 112. I know OGG is not a bitrated encoder, but rather uses quality levels 1-10 (I think?), but I always got ~192kbs using quality level 6, but now it does not seem so.

Anyone know of something I might be overlooking her, perhaps something not quite set right... here is the confg I am using in my home dir... actually I did notice there is an /etc/abcde.conf file, but all options are commented out. I wonder if perhaps there is another abcde.conf file being used somewhere and not the one i created in ~/.abcde. I think that is how the file should be named; does that look right does anyone know?


# -----------------$HOME/.abcde.conf----------------- #
#
# A sample configuration file to convert music cds to
# Ogg Vorbis using abcde version 2.3.99.6
#
# http://andrews-corner.org/abcde.html
# -------------------------------------------------- #

# Specify the encoder to use for Ogg Vorbis. In this case
# vorbize is the other choice.
OGGENCODERSYNTAX=oggenc

# Specify the path to the selected encoder. In most cases the encoder
# should be in your $PATH as I illustrate below, otherwise you will
# need to specify the full path. For example: /usr/bin/oggenc
OGGENC=oggenc

# Specify your required encoding options here. Multiple options can
# be selected as '-q 6 --another-option' etc.
OGGENCOPTS='-q 6'

# Output type for Ogg Vorbis
OUTPUTTYPE="ogg"

# The cd ripping program to use. There are a few choices here: cdda2wav,
# dagrab, cddafs (Mac OS X only) and flac.
CDROMREADERSYNTAX=cdparanoia

# Give the location of the ripping program and pass any extra options:
CDPARANOIA=cdparanoia
CDPARANOIAOPTS="--never-skip=40"

# Give the location of the CD identification program:
CDDISCID=cd-discid

# Give the base location here for the encoded music files.
OUTPUTDIR="$HOME/ripped/"
#OUTPUTDIR=/media/music/ripped/

# The default actions that abcde will take.
ACTIONS=cddb,playlist,read,encode,tag,move,clean

# Decide here how you want the tracks labelled for a standard 'single-artist',
# multi-track encode and also for a multi-track, 'various-artist' encode:
OUTPUTFORMAT='${OUTPUT}/${ARTISTFILE}_${ALBUMFILE}/${TRACKNUM}_${TRACKFILE}'
VAOUTPUTFORMAT='${OUTPUT}/Various_${ALBUMFILE}/${TRACKNUM}_${ARTISTFILE}_${TRACKFILE}'

# Decide here how you want the tracks labelled for a standard 'single-artist',
# single-track encode and also for a single-track 'various-artist' encode.
# (Create a single-track encode with 'abcde -1' from the commandline.)
ONETRACKOUTPUTFORMAT='${OUTPUT}/${ARTISTFILE}_${ALBUMFILE}/${ALBUMFILE}'
VAONETRACKOUTPUTFORMAT='${OUTPUT}/Various_${ALBUMFILE}/${ALBUMFILE}'

# Create playlists for single and various-artist encodes. I would suggest
# commenting these out for single-track encoding.
PLAYLISTFORMAT='${OUTPUT}/${ARTISTFILE}_${ALBUMFILE}/${ALBUMFILE}.m3u'
VAPLAYLISTFORMAT='${OUTPUT}/Various_${ALBUMFILE}/${ALBUMFILE}.m3u'

# Put spaces in the filenames instead of the more correct underscores:
mungefilename ()
{
echo "$@" | sed s,:,-,g | tr / _ | tr -d \'\"\?\[:cntrl:\]
}

# What extra options?
MAXPROCS=2 # Run a few encoders simultaneously
PADTRACKS=y # Makes tracks 01 02 not 1 2
EXTRAVERBOSE=y # Useful for debugging
EJECTCD=y # Please eject cd when finished :-)pretty basic, but mebe something needs to be changed?

cheers,
tt

thaitang
March 8th, 2011, 05:37 AM
Ok sorry about the useless post. DOH! I can see the file needs to be named ~/.abcde.CONF ! Working as expected now. Sheesh.