PDA

View Full Version : Firefox add-ons not working



Rulius
March 4th, 2011, 09:32 PM
Hi all,

I'm not sure if I'm supposed to post this here, since it IS a Firefox issue BUT in win 7.

Anyway here it is: I noticed that my Firefox add-ons are not working even though they are "namely" enabled. These include among others "Better Privacy" and "NoScript" (those are basically the ones I'm concerned about).
I go to the add-ons window, they seem to be enabled, when I click the options button the whole window freezes and I have to close it through task manager. I tried disabling them - restart Firefox - re-enabling them - restarting Firefox --- no good. I also went to help-> troubleshooting information and they are all marked as enabled. Nevertheless, neither of them is working: No NoScript icon, no script blocking, no Better Privacy pop-up when I exit the browser - nothing. I remember updating falsh player earlier today...

Any ideas?

Thanks.

howefield
March 4th, 2011, 09:37 PM
Moved to the Cafe should anyone wish to help.

colmesany
March 4th, 2011, 09:43 PM
I once had issues with just about any add-on I try to use, turns out a bad Firefox installation. Re-install and see if it helps.

Rulius
March 6th, 2011, 05:01 PM
Thanks for the advice colmesany!

I guess it was due to a "bad" update. I think this occurred while updating from 3.6.13 to 3.6.14. I updated to 3.6.15, but still had the same problem. Re-installed 3.6.14 and 3.6.15, with no success. When I re-installed to 3.6.13 the problem vanished http://ubuntuforums.org/images/smilies/confused.gif.
Finally, out of curiosity and in order to stay up-to-date, I completely removed Firefox and installed 3.6.15 and that worked too. For the story, I have Firefox on an "XP" and an "Ubuntu" pc and had no problems with that specific update 3.6.13 --> 3.6.14 , 3.6.15. Anyway, I guess it was accidental. I'm a bit frustrated though, as this happened silently.

Cheers! http://ubuntuforums.org/images/smilies/new_popcornsmiley.gif

JohnnyBlaze
March 8th, 2011, 08:55 AM
Exact same thing happened to me today.. tried uninstalling some, reinstalling, updating back and forth between *.14 and *.15 with no luck.. without the extensions it's like someone castrated firefox! I tried deleting extentions.ini, extensions.cache, and extensions.rdf and restarting with no luck! gonna keep searching but let me know what you find out! thanks!