View Full Version : [ubuntu] 10.04 LTS upgrade trainwreck

March 3rd, 2011, 11:07 PM
I'm a very, very basic user. I have 10.04 LTS as sole OS. I have had no serious problems running updates and getting upgrades/new installs until now. I think I came in around 8.04 or somewhere in that range. Anyway... this morning I allowed the update manager to do its thing and walked away for an hour. When I came back two strange and alarming things had happened:

1. there was a Microsoft EULA window regarding some kind of corefont install floating on top of the upgrade manager window. There was no option to close the EULA window, nor was I willing to click through the agreement- why should I since I have no MS software anywhere on my machine, and have no desire to allow any on it? I frustratedly clicked at the kill button on the underlying update manager window a couple of times, whereupon the MS EULA window launched itself into a process and disappeared.Next...

2. the upgrade manager began to install the upgrades and then disappeared, leaving a black screen.

After an hour of staring at my essentially dead computer, I powered down and then tried to restart.
I got a brief flash of a 10.10 start screen, then a black boot screen reading:
Boot from (hd0,0) ext 3 8d1362ec-db92-440f-9e0a-5b8aee40d123
which then hung out for an hour until I tried to restart again.
This time I got an screen full of this message: worker <215> did not accept message connection refused, kill it ((the brackets around 215 were square, and each new line was one number higher, as in 215, 216, 217)) and then it went back to the boot screen cited directly above, and hung for an hour and counting...

I'm really scared, and more than a little frustrated. Does anyone know enough to spot what may have happened here? I'm communicating from another machine now, since I can get absolutely nowhere with the "updating" machine.

Thank you very much!

Just tried to restart again, and this time I noticed that the brief flash of the start page actually says 10.04.

March 4th, 2011, 12:03 AM
Do you perhaps have Wine installed on your machine? If I remember correctly, I had to accept a MS EULA window recently, for using some of their fonts in Wine applications.

You probably have botched the update by aborting it before it ran to completion, and now needs re-doing. It could be best to boot from a previous working kernel, and re-do the update.

March 4th, 2011, 02:36 AM
The MS EULA also appears if there isn't Wine on the machine.

If I remember correctly, it is safe to answer Yes/OK to the first EULA screen, and after that one gets a screen with the option of refusing.

The MS fonts are not necessary, and my system has not had any problems after refusing.