PDA

View Full Version : [ubuntu] Color hue off on Youtube videos and Totem



Joseph_Dantes
March 3rd, 2011, 04:01 PM
My color hue skews red for youtube videos (but not when played on on youtube/leanback).

I get normal hue on megavideo, and on VLC player.

On Totem, I get blue hue.

I tried to adjust in the Totem edit->preferences->video tab, but I don't have a hue balance, only contrast and brightness.

I tried editing hue in gconf for totem, but the hue keeps resetting after I changed it, even if I lock my changes by setting them as default or mandatory.

I'm at a loss.

I'm primarily interested in fixing the Youtube. I think Totem may have developed its hue problem while I was trying various fixes, but I don't need Totem.

This problem started after I ran a scheduled update using Ubuntu's update manager.

I am using Ubuntu Lucid Lynx 10.04 LTS.

I'm not sure where to access my video card info, if that's relevant.

Bazint
March 3rd, 2011, 05:34 PM
This happened to me today too (for youtube), on Ubuntu 10.10.

As far as I can tell, the problem is not an update from Ubuntu, but an update from youtube. Youtube seems to have just started streaming a buggy video to browsers using flash 10.2, but it only affects linux users.

So far, there are three possible solutions I can think of:



Remove the cookie identifying your flash version.

When viewing the reddish youtube video, in firefox, click Edit>Preferences
Go to Privacy and click the "Show Cookies" button.
Delete the cookie called "PREF" from youtube.com.
Then refresh the video, and the red tinge should be gone.
You may have to do this process for every video you want to watch, or else find an extension to block that particular cookie.


Block all cookies from youtube.com

click Edit>Preferences
Go to Privacy and click the "Exceptions" button.
add youtube.com to the list of blocked cookies
This solution is more permanent, but it means you cannot log in to youtube (to make comments, upvote, etc)


Or simply install a different version of Flash... maybe try an older one? 10.1 or 10.0?


Edit: As for totem, try running the program "gstreamer-properties" from the terminal and choose a different video output module.

thepanch
March 3rd, 2011, 09:42 PM
same thing happened to me, i just installed the latest update, still in 10.10 and youtube in chrome has turned all pinky/redy i might just try "turning it off and on again" that might do the trick

thepanch
March 3rd, 2011, 10:35 PM
well the restart didnt fix it :(. my dads computer hasnt had the upgrade but is still displaying normal coloured video (his is a 32-bit version, mine is a 64-bit dont know if that makes any difference) but also the embedded versions of videos dont have the pink effect any help??
i disabled the cookies for youtube.com and that removed the pinkness, but i not signed in or anything :( any other possible fixes?
thanks p

matt1950
March 4th, 2011, 01:58 AM
I did the update to 10.10 last night and all of my YouTube videos were red.
The upgrade installed version 10.2.152.27 of Flash player.
I was able to get the colors back to normal by downgrading my Flash version.
I went to Synaptic Package Manager and choose Package -> Force version.
Then when I selected "flashplugin-installer" from the package list, it
asked me what version I wanted to downgrade to, so I selected "10.0.45.2ubuntu1".
I applied this change and the YouTube videos look like normal now...

pterion
March 4th, 2011, 01:07 PM
Same here at Ubuntu Lucid 10.04 and the new flash player 10.2.x.
Waiting for YouTube to fix this embarrassment.

See screenshot.

Paddy Landau
March 4th, 2011, 03:01 PM
See this thread for workarounds:
http://ubuntuforums.org/showthread.php?t=1698956

thepanch
March 7th, 2011, 11:06 PM
I did the update to 10.10 last night and all of my YouTube videos were red.
The upgrade installed version 10.2.152.27 of Flash player.
I was able to get the colors back to normal by downgrading my Flash version.
I went to Synaptic Package Manager and choose Package -> Force version.
Then when I selected "flashplugin-installer" from the package list, it
asked me what version I wanted to downgrade to, so I selected "10.0.45.2ubuntu1".
I applied this change and the YouTube videos look like normal now...
this method worked for me in google chrome thank you

KeesM
January 14th, 2012, 11:01 AM
I had a recent shift towards blue for YouTube videos. This actually started when I fixed Flash support using the Flash Aid add-on and selected the default 'Adobe Beta' version. Selecting the 'Adobe Stable, from repositories (32 bit)' from the advanced Flash Aid settings solved the color shift. Guess the beta is still beta for a reason. Running Ubuntu 11.04 64 bit.

Edit: Oops, I now get complaints from my wife as Facebook video is no longer working; it needs this latest beta version... So either blue videos but facebook working, or normal video and no facebook?

Edit again: by switching off hardware acceleration, it now seems to work. However, it was some effort to find a site on which I actually could change the settings; on many sites, I can get to the Flash menu (right-click, select Settings), but the menu then freezes (can not click/change anything in the popup, not even close).

DrKaoliN
March 30th, 2012, 09:52 PM
Here's how I solved it:
shared a youtube video on my facebook,
went full screen,
and disabled hardware acceleration.

paxh2o
March 31st, 2012, 10:11 AM
I did the update to 10.10 last night and all of my YouTube videos were red.
The upgrade installed version 10.2.152.27 of Flash player.
I was able to get the colors back to normal by downgrading my Flash version.
I went to Synaptic Package Manager and choose Package -> Force version.
Then when I selected "flashplugin-installer" from the package list, it
asked me what version I wanted to downgrade to, so I selected "10.0.45.2ubuntu1".
I applied this change and the YouTube videos look like normal now...


thanks! it worked for me too!

vxd240
April 6th, 2012, 04:31 PM
Ubuntu 10.10
Downgrade Flash: did not work
Remove/Block cookies: did not work
Disable hardware acceleration: Win!

Using chrome, I got the same "frozen" menu (right-click on flash video-->settings). However, I used Firefox to do the same thing and it worked (controls both FF & chrome flash playback).

SeijiSensei
April 6th, 2012, 04:43 PM
Disable hardware acceleration: Win!

Wow, that's annoying, especially since the current version of Flash for Linux is the last to ever be released. Way to go, Adobe, leaving us with a buggy version at the end of the line.

I hadn't noticed this problem until I watched a couple of videos on YouTube this morning. Turning off HW acceleration and reloading the video eliminated the excessive blue tint entirely.

I have a machine whose CPU is fast enough not to need to use hardware acceleration, but that's not true for lots of other people on lower-powered platforms like early Atom processors.

Is this only true for NVIDIA/VDPAU+Flash, or do machines with ATI adapters also have this problem? If it's only a problem with NVIDIA cards, maybe the issue is with their proprietary driver and not Adobe's fault.

Update: It seems to be a problem between Flash 11.2 and VDPAU. See these bug reports:

https://bugs.launchpad.net/ubuntu/+source/adobe-flashplugin/+bug/967091
https://bugs.launchpad.net/ubuntu/+source/flashplugin-nonfree/+bug/968647

It's probably the result of poor quality control on Adobe's part, and their response so far is, "sorry, but we're done supporting Linux." Maybe NVIDIA can make some changes to libvdpau1 to compensate for Adobe's carelessness. We'll see.

jt_04
April 6th, 2012, 07:37 PM
Here's how I solved it:
shared a youtube video on my facebook,
went full screen,
and disabled hardware acceleration.

this did the trick for me, thanks very much (except I didn't share a video on facebook, just played one on youtube, went full screen, right click -> settings, and turned off hardware acceleration)

Paddy Landau
April 7th, 2012, 11:48 AM
I am surprised to see this is an ongoing issue. I thought it had been fixed months ago.

I have tested on both 11.04 and 12.04 Beta, and both work correctly with hardware acceleration enabled. Are you using older versions perhaps? Or could the hardware in question be making a difference?

balta
April 10th, 2012, 10:27 PM
The hardware acceleration disabling totally did the trick for me.
I was getting totally sick of blueish videos :D
Thanks a lot

BigSilly
April 11th, 2012, 08:18 AM
Here's how I solved it:
shared a youtube video on my facebook,
went full screen,
and disabled hardware acceleration.

Yup, this did it for me across both of my Linux installs. Many thanks. :)

What a mess though. Massively disappointed.

lovinglinux
April 13th, 2012, 02:27 PM
See http://ubuntuforums.org/showthread.php?t=1953796

ricardisimo
April 15th, 2012, 04:16 AM
Not me. Enabled or disabled, same result. Curiously, the previewer function in the YouTube player accurately renders the colors, as the screenshot shows. Sorry if the content offends, but I asked for skin, and I got it. Notice the previewer of the same image.

11.10 here, everything updated as far as I know.

Paddy Landau
April 15th, 2012, 09:44 AM
Enabled or disabled, same result.
You may have to log out and in again (or reboot) after disabling. Did you try that?

ricardisimo
April 16th, 2012, 12:11 AM
No change. Still blues. Uggh. Why just YouTube? I don't get it.

SeijiSensei
April 16th, 2012, 12:34 AM
No change. Still blues. Uggh. Why just YouTube? I don't get it.

Read the bug reports that I linked to above (http://ubuntuforums.org/showpost.php?p=11822694&postcount=13). It's a bad interaction between something called stage video in Flash and the NVIDIA driver. YouTube uses "stage video" so the problem occurs there.

Just to confirm, you do have an NVIDIA card, and you are using the proprietary driver, correct? As far as I know, disabling hardware acceleration should fix the problem.

Just to check, if you choose Tools > Add-Ons > Plug-ins, you'll see your Flash version. What is it?

Those girls were cute in blue, though.

Update: After re-reading the bug report thread, it looked like NVIDIA might have released a new driver version that includes a hack to deal with the problem. On my fully-updated 12.04 system with the most recent release of nvidia-current, the problem persists. I can still cure it by turning off hardware acceleration and closing and re-opening Firefox.

ricardisimo
April 16th, 2012, 03:39 AM
Shockwave Flash 11.2 r202

OK... weird. This (http://www.youtube.com/watch?v=oP7JMnIOSP0&feature=related) YouTube video is messed up (along with most every other one I look at), but this one (http://www.youtube.com/watch?v=onlIemGdMD4&feature=context&context=G26a16aaRVAAAAAAAAAA) and most other NFL videos are just fine. So, now what's up?

SeijiSensei
April 16th, 2012, 05:16 AM
The model in the first video is definitely flesh-colored here.

NVIDIA 9500GT with driver 295.40-0ubuntu1
libvdpau1 0.4.1-3ubuntu1
Flashplayer 11.2.202.228 with HW acceleration disabled

Paddy Landau
April 16th, 2012, 09:37 AM
OK... weird. This (http://www.youtube.com/watch?v=oP7JMnIOSP0&feature=related) YouTube video is messed up (along with most every other one I look at), but this one (http://www.youtube.com/watch?v=onlIemGdMD4&feature=context&context=G26a16aaRVAAAAAAAAAA) and most other NFL videos are just fine.
Right-click on each video. You'll notice that the first one is a Flash video, while the second is done through HTML5. (I don't know the technical differences, but I did notice the difference.)

ricardisimo
April 23rd, 2012, 11:19 AM
Not sure what to do about this. Still blue flesh here. :-(

lovinglinux
April 24th, 2012, 03:35 AM
Not sure what to do about this. Still blue flesh here. :-(


Please attach the firefox-report.txt file generated in your desktop after running the commands below:



echo 'Ubuntu Architecture' > ~/Desktop/firefox-report.txt
echo '' >> ~/Desktop/firefox-report.txt
uname -a >> ~/Desktop/firefox-report.txt
echo '' >> ~/Desktop/firefox-report.txt
echo 'Ubuntu Version' >> ~/Desktop/firefox-report.txt
echo '' >> ~/Desktop/firefox-report.txt
cat /etc/lsb-release >> ~/Desktop/firefox-report.txt
echo '' >> ~/Desktop/firefox-report.txt
echo 'Firefox Packages' >> ~/Desktop/firefox-report.txt
echo '' >> ~/Desktop/firefox-report.txt
dpkg --get-selections | grep 'firefox*' >> ~/Desktop/firefox-report.txt
echo '' >> ~/Desktop/firefox-report.txt
echo 'Firefox binaries' >> ~/Desktop/firefox-report.txt
echo '' >> ~/Desktop/firefox-report.txt
which firefox >> ~/Desktop/firefox-report.txt
file /usr/bin/firefox >> ~/Desktop/firefox-report.txt
file /usr/local/bin/firefox >> ~/Desktop/firefox-report.txt
file /opt/firefox/firefox >> ~/Desktop/firefox-report.txt
echo '' >> ~/Desktop/firefox-report.txt
echo 'Firefox divertion' >> ~/Desktop/firefox-report.txt
echo '' >> ~/Desktop/firefox-report.txt
file /usr/bin/firefox.ubuntu >> ~/Desktop/firefox-report.txt
echo '' >> ~/Desktop/firefox-report.txt
echo 'Sources' >> ~/Desktop/firefox-report.txt
echo '' >> ~/Desktop/firefox-report.txt
ls /etc/apt/sources.list.d >> ~/Desktop/firefox-report.txt
echo '' >> ~/Desktop/firefox-report.txt
echo 'Flash packages' >> ~/Desktop/firefox-report.txt
echo '' >> ~/Desktop/firefox-report.txt
dpkg --get-selections | grep 'flash*' >> ~/Desktop/firefox-report.txt
echo '' >> ~/Desktop/firefox-report.txt
echo 'Plugin locations' >> ~/Desktop/firefox-report.txt
echo '' >> ~/Desktop/firefox-report.txt
locate libflashplayer.so >> ~/Desktop/firefox-report.txt
echo '' >> ~/Desktop/firefox-report.txt
locate flashplugin-alternative.so >> ~/Desktop/firefox-report.txt
echo '' >> ~/Desktop/firefox-report.txt
echo 'Flash symlinks' >> ~/Desktop/firefox-report.txt
echo '' >> ~/Desktop/firefox-report.txt
file /usr/lib/firefox-addons/plugins/libflashplayer.so >> ~/Desktop/firefox-report.txt
file /usr/lib/mozilla/plugins/flashplugin-alternative.so >> ~/Desktop/firefox-report.txt
file /etc/alternatives/mozilla-flashplugin >> ~/Desktop/firefox-report.txt
file /var/lib/flashplugin-installer/npwrapper.libflashplayer.so >> ~/Desktop/firefox-report.txt
echo '' >> ~/Desktop/firefox-report.txt
echo 'pluginreg.dat' >> ~/Desktop/firefox-report.txt
echo '' >> ~/Desktop/firefox-report.txt
cat ~/.mozilla/firefox/**/pluginreg.dat >> ~/Desktop/firefox-report.txt
firefox ~/Desktop/firefox-report.txt

DiFS
April 25th, 2012, 05:26 PM
I have the same problem of ricardisimo.


Please attach the firefox-report.txt file generated in your desktop after running the commands below:

lovinglinux
April 25th, 2012, 05:32 PM
I have the same problem of ricardisimo.

Have you tried these?

http://ubuntuforums.org/showthread.php?t=1953796

ricardisimo
May 1st, 2012, 10:40 AM
Please attach the firefox-report.txt file generated in your desktop after running the commands below:

Please see attached. Thank you so much.

P.S. - "Your file of 26.0 KB bytes exceeds the forum's limit of 19.5 KB for this filetype." Therefore I have split it into two text files.

lovinglinux
May 2nd, 2012, 01:50 AM
Please see attached. Thank you so much.

P.S. - "Your file of 26.0 KB bytes exceeds the forum's limit of 19.5 KB for this filetype." Therefore I have split it into two text files.


I couldn't determine which version of flash you are using. Apparently you have more than one Firefox profile and some haven't be used recently.

These are the versions listed in their pluginreg.dat:

10.0 r45 /usr/lib/adobe-flashplugin/libflashplayer.so

10.0 r32 /usr/lib/flashplugin-installer/libflashplayer.so

10.1 r85 /usr/lib/flashplugin-installer/libflashplayer.so

Open about:plugins and verify which version you really has.

Trucoto
May 2nd, 2012, 03:48 AM
This bug is being discussed here (https://bugs.launchpad.net/ubuntu/+source/adobe-flashplugin/+bug/967091). Please go where they say to upvote the Adobe bug so they can fix it.

ricardisimo
May 2nd, 2012, 11:37 PM
Open about:plugins and verify which version you really has.

Shockwave Flash

File: libflashplayer.so
Version:
Shockwave Flash 11.2 r202

MIME Type Description Suffixes
application/x-shockwave-flash Shockwave Flash swf
application/futuresplash FutureSplash Player spl

lastguru
May 2nd, 2012, 11:43 PM
I had this problem with latest flash and nvidia card. I actually just installed vdpau, which was not installed for some reason, and everything returned back to normal. Maybe it will help someone else...

ricardisimo
May 3rd, 2012, 04:37 AM
Was it vdpau-va-driver you installed? That's all that was in the repositories, and I tried it, but no dice.

lastguru
May 3rd, 2012, 12:25 PM
libvdpau1

An interesting observation is that I needed to reinstall this library after nvidia driver upgrade. Probably a bug.

ricardisimo
May 3rd, 2012, 03:33 PM
Already installed. Thanks anyway.

ricardisimo
May 15th, 2012, 11:50 PM
Still no love from YouTube. Anyone have any other ideas? Thanks.

johnko99
May 18th, 2012, 02:56 PM
My color hue skews red for youtube videos (but not when played on on youtube/leanback).

I get normal hue on megavideo, and on VLC player.

On Totem, I get blue hue.

I tried to adjust in the Totem edit->preferences->video tab, but I don't have a hue balance, only contrast and brightness.

I tried editing hue in gconf for totem, but the hue keeps resetting after I changed it, even if I lock my changes by setting them as default or mandatory.

I'm at a loss.

I'm primarily interested in fixing the Youtube. I think Totem may have developed its hue problem while I was trying various fixes, but I don't need Totem.

This problem started after I ran a scheduled update using Ubuntu's update manager.

I am using Ubuntu Lucid Lynx 10.04 LTS.

I'm not sure where to access my video card info, if that's relevant.
I solved the same problem in Firefox/youtube using http://www.youtube.com/html5! Just join the HTML5 use!

lovinglinux
May 19th, 2012, 03:36 PM
I solved the same problem in Firefox/youtube using http://www.youtube.com/html5! Just join the HTML5 use!

Well, that doesn't work for all YT videos. Since they still cannot pipe ads on HTML5, I doubt they will fully replace flash.

ricardisimo
May 19th, 2012, 07:12 PM
Well, that doesn't work for all YT videos. Since they still cannot pipe ads on HTML5, I doubt they will fully replace flash.

Well, it is working so far for me. I saw that it doesn't support h.264, so most likely a decent number of these will revert to Flash... or no? Will I just not be able to see them? Is Flash eventually going to be fixed?

lovinglinux
May 20th, 2012, 01:38 AM
Well, it is working so far for me. I saw that it doesn't support h.264, so most likely a decent number of these will revert to Flash... or no? Will I just not be able to see them? Is Flash eventually going to be fixed?

Yes, it will fallback to flash if your browser doesn't support the html5 encoding.

Flash is not going to be fixed. Adobe has dropped support for Flash on Linux and will only provide security updates. However, they also made a deal with Google so they can deliver PepperFlash with Chrome. Bottom-line, only Chrome will have new major flash versions and bug fixes.

Paddy Landau
May 20th, 2012, 08:39 AM
I saw that it doesn't support h.264...
Me too. I am concerned about that, because eventually Flash will die and HTML5 will completely take over. Will we Linux users be stuck after that?


... However, they also made a deal with Google so they can deliver PepperFlash with Chrome. Bottom-line, only Chrome will have new major flash versions and bug fixes.
Interesting. That may persuade a few people to change to Chrome, but most users (I believe) use Internet Explorer and will remain doing so.

lovinglinux
May 20th, 2012, 09:09 AM
Me too. I am concerned about that, because eventually Flash will die and HTML5 will completely take over. Will we Linux users be stuck after that?


Interesting. That may persuade a few people to change to Chrome, but most users (I believe) use Internet Explorer and will remain doing so.

Firefox, Opera and Chrome supports WebM. Chrome supports h.264 as well. So, Linux users will still have the ability play h.264 and flash, using Chrome.

Mozilla recently decided to support h.264 on mobile and possibly will support it on desktop. Only time will tell.

westniall
July 17th, 2012, 08:27 PM
@DrKaoliN WORKED! Tnx

rizal23
July 18th, 2012, 03:00 AM
This happened to me today too (for youtube), on Ubuntu 10.10.

As far as I can tell, the problem is not an update from Ubuntu, but an update from youtube. Youtube seems to have just started streaming a buggy video to browsers using flash 10.2, but it only affects linux users.

So far, there are three possible solutions I can think of:



Remove the cookie identifying your flash version.

When viewing the reddish youtube video, in firefox, click Edit>Preferences
Go to Privacy and click the "Show Cookies" button.
Delete the cookie called "PREF" from youtube.com.
Then refresh the video, and the red tinge should be gone.
You may have to do this process for every video you want to watch, or else find an extension to block that particular cookie.


Block all cookies from youtube.com

click Edit>Preferences
Go to Privacy and click the "Exceptions" button.
add youtube.com to the list of blocked cookies
This solution is more permanent, but it means you cannot log in to youtube (to make comments, upvote, etc)


Or simply install a different version of Flash... maybe try an older one? 10.1 or 10.0?


Edit: As for totem, try running the program "gstreamer-properties" from the terminal and choose a different video output module.




I agree with this solution, because I've proved it does work.
Thank you.