View Full Version : [ubuntu] 10.10 kernel update and grub problem

March 2nd, 2011, 10:11 PM
OK, I've got a minor issue and an underlying problems here.

The minor issue is that today I updated the kernel (to the newest) and when I rebooted I only get a text interface. Doing some research and with a history of problems I had with Ubuntu versions and kernels previous to 10.10, this is likely due to a video driver problem. I'm running an ATI HD5770 (it's my first ATI card and I've been very unhappy with it's lack of playing nice with Linux) and since 10.10 have been able to successfully run ATI's drivers and Catalyst Control Center, which I need for crossfire and ATI's weird over/underscan on 1080p displays. So to 'fix' my text mode problem I'm guessing I will need to reconfig xorg.conf per this thread:

Or remove the new kernel to revert to the old kernel.

Which brings me to an underlying problem with Ubuntu/grub/my hardware. I recently added a second SSD for my Windows install, a Crucial c300 on the Marvell 9128 SATA3 controller on my ASUS P6X58D mobo (in BIOS, its set to RAID, but I've set it to AHCI and IDE with the same results, and I use the controller for a RAID 1 on my storage drives so I leave it in RAID). It was a pain to get Windows installed on it, but even worse is that Ubuntu does not even recognize the drive so I'm unable to install grub to the MBR/Win7 drive, so just booting to my old kernel is more difficult. What I ended up having to do is finding a bootloader I could install through Windows which would allow me to boot to Win7 and Ubuntu. So I found EasyBCD which does just that, except it gives me the option to boot to Ubuntu or Win7, but doesn't tell me any more info and since I've updated my kernel previously with no problems in Ubuntu, I assume EasyBCD automatically boots the newest kernel version. Which has been fine until now.

If reconfiguring xorg.conf doesn't work should I try to remove the new kernel (I'm assuming I can do this in text mode with apt-get --purge remove <linux-image-2.x.x.x>)?
Also, are there any ideas on how to get Ubuntu to recognize the new SSD so I can use grub? Or does anyone have experience with EasyBCD so I can get a more grub like experience from it (like booting to older kernels that aren't yet removed)?

Sorry there is so much information, but I'd really appreciate some help on this.

March 4th, 2011, 05:27 AM
sudo aticonfig --initial

didn't fix it.
So I tried


which gave a bunch of text, and got to:

10: /usr/bin/X (0x400000+0x21409) [0x421409]
Segmentation fault at address 0xa0

Caught signal 11 (Segmentation fault). Server aborting.

<some stuff about logs and the x.org wiki page>

(EE) fglrx(0): firegl_SetSuspendResumeState FAILED -9.
ddxSigGiveUp: Closing log
giving up.

So, I'm getting a seg fault trying to start X11? I think I may be able to get the whole log if it would help....

March 4th, 2011, 07:01 AM
Tried using xorg.conf-original-0 (or something with a name like that) and now there is no video at all on boot. So, looks like it's time for a reinstall, but I'm not very happy about this, because as soon as I update I'm expecting the same thing to happen.