PDA

View Full Version : [ubuntu] No sound Ubuntu 10.10 Asus laptop N82J



etiennenoel
March 1st, 2011, 07:37 PM
Hi,

I have an Asus N82J and I don't have sound. ? Can someone give me clue please on where I can start ?

Thank you very much

Etienne

etiennenoel
March 1st, 2011, 08:02 PM
Strangest thing, the sound works by using the headphone jack. Can someone guide me in order to resolve this problem ?

Thank you very much !

etiennenoel
March 1st, 2011, 08:08 PM
I also want to mention that nothing is muted under alsamixer and I can control the sound of the headphones as well as the master, but nothing comes out.

etiennenoel
March 2nd, 2011, 01:13 AM
Hi Everyone,

I follow the comprehensive guide step by step but it seems that my sound card isn't supported.

Can someone suggest me something?

Thanks in advance !

lidex
March 2nd, 2011, 02:12 AM
Hard to know without some system info.
Use the alsa-info-script to provide detailed information.
Run this command in a terminal:

wget http://www.alsa-project.org/alsa-info.sh -O alsa-info.sh && bash alsa-info.sh
Choose the upload option and provide a link for the output.
[Terminal="Applications->Accessories->Terminal"]

etiennenoel
March 2nd, 2011, 02:21 AM
Thank you very much for your time.

http://www.alsa-project.org/db/?f=f19324ba1698e62530bf18604db63e568d42b11c

I think this is what you meant by upload.

Thanks again

lidex
March 2nd, 2011, 03:14 AM
OK. Remove the edit you made to alsa-base.conf then try updating your alsa-driver-modules.
Using a Terminal="Applications->Accessories->Terminal"
Add the ubuntu-audio-dev ppa:

sudo add-apt-repository ppa:ubuntu-audio-dev/ppa
sudo apt-get update
Now install:

sudo apt-get install linux-alsa-driver-modules-$(uname -r)
Reboot
Check your levels in alsamixer.

alsamixer
Press <F6> to select the correct soundcard.
Press <F3> to show playback levels. <F4> selects capture levels [or use <Tab>]
Use the left/right arrow keys to select and up/down arrow keys to change levels. <M> to mute/unmute.
Go to "System ->Preferences ->Sound" and make sure the correct soundcard is default and adjust your profile on the hardware tab.
On the output tab choose the correct device.

etiennenoel
March 2nd, 2011, 03:29 AM
Unfortunately, it still doesn't work. I tried to put it on every profile without success. Do you have any other clues ? When I tried what you told me, I got more choices in the output tab. I try to do what they mention in another forum but without success... http://ubuntuforums.org/showthread.php?t=1658502

Thank you very much for you help and I hope this will get resolved !

lidex
March 2nd, 2011, 04:14 AM
Have you tried raising the level on the 'Speaker Playback Volume' in alsa mixer. It's currently set at zero.


control.1 {
comment.access 'read write'
comment.type INTEGER
comment.count 2
comment.range '0 - 87'
comment.dbmin -6525
comment.dbmax 0
iface MIXER
name 'Speaker Playback Volume'
value.0 0
value.1 0
}
control.2 {
comment.access 'read write'
comment.type BOOLEAN
comment.count 2
iface MIXER
name 'Speaker Playback Switch'
value.0 true
value.1 true

etiennenoel
March 2nd, 2011, 04:27 AM
In alsamixer, there is nothing named speaker playback volume. but htere is something named speaker that is at 100.

lidex
March 2nd, 2011, 03:22 PM
In alsamixer, there is nothing named speaker playback volume. but htere is something named speaker that is at 100.
Then try gnome-alsamixer.
Gnome-alsamixer
Using Alt+F2 run dialog

gnome-alsamixer
Use 'Edit -> Sound Card Properties' menu to enable elements.
Soundcard tab to select / adjust levels.
To install:

sudo apt-get install gnome-alsamixer

etiennenoel
March 2nd, 2011, 03:55 PM
I have it installed but it is not shown there either...

lidex
March 2nd, 2011, 04:04 PM
Do you have all the elements enabled in the 'Edit -> Sound Card Properties' menu?

etiennenoel
March 2nd, 2011, 04:08 PM
Yes, everything is enabled. Thanks again for your time.

lidex
March 2nd, 2011, 04:13 PM
Did you remove that line from alsa-base.conf? Can you post an updated alsa-info script please?

wget http://www.alsa-project.org/alsa-info.sh -O alsa-info.sh && bash alsa-info.sh

etiennenoel
March 2nd, 2011, 04:18 PM
http://www.alsa-project.org/db/?f=e0ff6fa20c816e9ec0d9800ab94e3f73bcd98df7

lidex
March 2nd, 2011, 04:27 PM
Did you remove that line from alsa-base.conf?
So you're saying you're not going to remove it?

etiennenoel
March 2nd, 2011, 04:28 PM
Sorry I don't understand what you mean. You want me to remove which line?

lidex
March 2nd, 2011, 04:33 PM
Open this file for editing:

gksudo gedit /etc/modprobe.d/alsa-base.conf

Find near the bottom, a line starting with:

options snd-hda-intel

Remove it, save, close, reboot.

etiennenoel
March 2nd, 2011, 04:39 PM
I removed the line you told me, and reboot but the sound still doesn't work. However, the sound still works with the headphone jack.

lidex
March 2nd, 2011, 05:14 PM
I'm drawing a blank here. The 2.6.34 kernel was supposedly patched for your codec - it should work. File a bug report for the audio devs to look at. Try running this command in a terminal for 10.04 or later:

ubuntu-bug audio
Reference the Ubuntu-Bug Audio link in my sig.

etiennenoel
March 2nd, 2011, 05:18 PM
Thanks for your time, I did what you told me. HEre is the link of the bug https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/727868 .

lidex
March 2nd, 2011, 05:25 PM
Thank you for following up so quickly. I'll keep an eye on it.

lokiguy
March 23rd, 2011, 05:23 AM
I had no sound in headphones - adding the ppa:ubuntu-audio-dev/ppa worked fine for me - just a reboot was all that was needed after that.

Thanks lidex!