PDA

View Full Version : [ubuntu] how can i turn on bluetooth adapter???



birdy.f
February 28th, 2011, 08:52 AM
hello..there is a messege coming that bluetooth has been disabled by a switch on ur computer,,..i really dont know how to turn it on..it was working fine in windows..but i really dont want to use windows again..guys out there can anyone help me !!

birdy.f
February 28th, 2011, 09:15 AM
I switched off my bluetooth in windows now how do i turn it in here?

zenwalker
February 28th, 2011, 09:17 AM
You sure you dont have a manual switch provided to switch it on or off?
http://www.thinkwiki.org/wiki/How_to_setup_Bluetooth

birdy.f
February 28th, 2011, 10:16 AM
no i dont have a manual switch ...i read here on the forums abt this exact same problem with someone else..so i guess m not the only person in this war ..:)
http://ubuntuforums.org/showthread.php?t=1681280

birdy.f
February 28th, 2011, 10:22 AM
there are errors also in firmware-b43-installer

vivek.pandey
February 28th, 2011, 10:30 AM
i too had a similar issue but my lapi has a key(antenna made over it). pressing it enabled bluetooth. i guess you should check your keys again as it says it has been disabled by a switch

birdy.f
February 28th, 2011, 10:42 AM
yes i found that switch...now it says that bluetooth is disabled.. when i press it again it says no bluetooth adapters found..

birdy.f
February 28th, 2011, 10:45 AM
i guess wat i need is Dell Wireless 365 bluetooth module driver.. (http://www.google.com/url?sa=t&source=web&cd=1&sqi=2&ved=0CBMQFjAA&url=http%3A%2F%2Fubuntuforums.org%2Farchive%2Finde x.php%2Ft-961651.html&rct=j&q=dell%20wireless%20365%20bluetooth%20module%20dri ver%20for%20ubuntu&ei=LGZrTcuTOIKO4gaxhqnfCQ&usg=AFQjCNFsm-pI6ORFNxTzmIaPf_24Ylm2IA&cad=rja)

i downloaded it from dell official site with windows but i guess i must have switched it off or something..before installing ubuntu,,and now i cant download this driver with ubuntu,,what should i do??

birdy.f
February 28th, 2011, 10:50 AM
running this command lsusb gives s me this..
Bus 002 Device 003: ID 09da:000a A4 Tech Co., Ltd Port Mouse
Bus 002 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 031: ID 413c:8162 Dell Computer Corp.
Bus 001 Device 030: ID 413c:8161 Dell Computer Corp.
Bus 001 Device 029: ID 0a5c:4500 Broadcom Corp. BCM2046B1 USB 2.0 Hub (part of BCM2046 Bluetooth)
Bus 001 Device 004: ID 0bda:0158 Realtek Semiconductor Corp. USB 2.0 multicard reader
Bus 001 Device 003: ID 0c45:641d Microdia
Bus 001 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

vivek.pandey
February 28th, 2011, 10:59 AM
k finally you got the key... go to filesystem->etc->bluetooth
open main.conf in a text editor
check this

# What value should be assumed for the adapter Powered property when
# SetProperty(Powered, ...) hasn't been called yet. Defaults to true
InitiallyPowered = true

birdy.f
February 28th, 2011, 11:00 AM
in additional drivers when i try to install broadcom B43 wireless driver this error occurs..
SystemError: installArchives() failed

birdy.f
February 28th, 2011, 11:00 AM
how do i activate it??

birdy.f
February 28th, 2011, 11:02 AM
ok neo plz dont go anywhere till u help me solve this!!i wud really appreciate!

birdy.f
February 28th, 2011, 11:10 AM
how can i go there??

vivek.pandey
February 28th, 2011, 11:10 AM
did you see the configuration file i asked you to see?

birdy.f
February 28th, 2011, 11:12 AM
how can i open this file??

vivek.pandey
February 28th, 2011, 11:16 AM
places->filesystem->etc->bluetooth->main.conf

also you can install the driver through terminal code will be
sudo apt-get install b43-fwcutter

vivek.pandey
February 28th, 2011, 11:17 AM
how can i open this file??

right click on the file open with text editor

birdy.f
February 28th, 2011, 11:22 AM
i mean there are thousands of files n folders in filesystem..i cannot find this bluetooth file!

vivek.pandey
February 28th, 2011, 11:26 AM
in file systems you will see a folder etc go inside it you will find bluetooth in alphabetical order or else you just type bluetooth you will see bluetooth folder highlighted

birdy.f
February 28th, 2011, 11:31 AM
[General]

# List of plugins that should not be loaded on bluetoothd startup
#DisablePlugins = network,input

# Default adaper name
# %h - substituted for hostname
# %d - substituted for adapter id
Name = %h-%d

# Default device class. Only the major and minor device class bits are
# considered.
Class = 0x000100

# How long to stay in discoverable mode before going back to non-discoverable
# The value is in seconds. Default is 180, i.e. 3 minutes.
# 0 = disable timer, i.e. stay discoverable forever
DiscoverableTimeout = 0

# How long to stay in pairable mode before going back to non-discoverable
# The value is in seconds. Default is 0.
# 0 = disable timer, i.e. stay pairable forever
PairableTimeout = 0

# Use some other page timeout than the controller default one
# which is 16384 (10 seconds).
PageTimeout = 8192

# Discover scheduler interval used in Adapter.DiscoverDevices
# The value is in seconds. Defaults is 0 to use controller scheduler.
DiscoverSchedulerInterval = 0

# What value should be assumed for the adapter Powered property when
# SetProperty(Powered, ...) hasn't been called yet. Defaults to true
InitiallyPowered = true

# Remember the previously stored Powered state when initializing adapters
RememberPowered = true

# Use vendor, product and version information for DID profile support.
# The values are separated by ":" and VID, PID and version.
#DeviceID = 1234:5678:abcd

# Do reverse service discovery for previously unknown devices that connect to
# us. This option is really only needed for qualification since the BITE tester
# doesn't like us doing reverse SDP for some test cases (though there could in
# theory be other useful purposes for this too). Defaults to true.
ReverseServiceDiscovery = true

# Enable name resolving after inquiry. Set it to 'false' if you don't need
# remote devices name and want shorter discovery cycle. Defaults to 'true'.
NameResolving = true

# Enable runtime persistency of debug link keys. Default is false which
# makes debug link keys valid only for the duration of the connection
# that they were created for.
DebugKeys = false

# Enable Low Energy support if the dongle supports. Default is false.
# Enable/Disable interleave discovery and attribute server over LE.
EnableLE = false

# Enable the GATT Attribute Server. Default is false, because it is only
# useful for testing. Attribute server is not enabled over LE if EnableLE
# is false.
AttributeServer = false

birdy.f
February 28th, 2011, 11:31 AM
found it!

birdy.f
February 28th, 2011, 11:32 AM
hey listen..i have power shortage right now! third world country..anyway will be able to switch on after 2 hours,..

vivek.pandey
February 28th, 2011, 11:37 AM
k fine when you switch it on just try installing broadcom from terminal using the command i gave

birdy.f
February 28th, 2011, 02:30 PM
ok using the command i got this error..

Reading package lists... Done
Building dependency tree
Reading state information... Done
b43-fwcutter is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 8 not upgraded.
1 not fully installed or removed.
After this operation, 0B of additional disk space will be used.
Do you want to continue [Y/n]? y
Setting up firmware-b43-installer (4.150.10.5-4) ...
Not supported low-power chip with PCI id 14e4:4315!
Aborting.
dpkg: error processing firmware-b43-installer (--configure):
subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
firmware-b43-installer
E: Sub-process /usr/bin/dpkg returned an error code (1)

birdy.f
February 28th, 2011, 02:37 PM
ok now i did it again activating broadcom wireless driver B43 from addition drivers then again using the command in terminal i got..

carpenoctem@carpenoctem-Inspiron-1564:~$ sudo apt-get install b43-fwcutter
Reading package lists... Done
Building dependency tree
Reading state information... Done
b43-fwcutter is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 8 not upgraded.

birdy.f
February 28th, 2011, 02:40 PM
ok when i click the receive files , it says that Plz verify that '' Personal file sharing'' is currently installed..

birdy.f
February 28th, 2011, 03:03 PM
ok i installed it ..but still..my bluetooth wont turn on..i mean it says bluetoooth is disabled..

birdy.f
February 28th, 2011, 04:06 PM
184707

184708

now when i open the preferences i get this when i should be getting things like show my device and all...

birdy.f
February 28th, 2011, 04:07 PM
when i click on the turn on button..nothing happens!

vivek.pandey
February 28th, 2011, 04:50 PM
when i click on the turn on button..nothing happens!

sorry had gone for dinner so couldnt reply... see what is supposed to happen when you click the bluetooth icon in the preferences you will get a bluetooth screen which says bluetooth disabled by a switch...something like this.then just click the bluetooth key on your keypad.this will bring the bluetooth screen which says turn on bluetooth a screen whose pic you attached wait for a couple of seconds without pressing anything

birdy.f
February 28th, 2011, 04:57 PM
when i click the turn on button whos pic iv attached...nothing happens! its lyk a min since m waiting..

vivek.pandey
February 28th, 2011, 05:34 PM
even in the attachment you sent you can see bluetooth is on.. the bluetooth icon one..try turning it off from the icon and then on and see if you can connect to any device everything seems to be ok...dont know where the problem is

birdy.f
February 28th, 2011, 05:37 PM
wen i go to system- preferences - bluetooth manager...an error occurs..it says connection failed to blueZ...maybe the prob lies there>>??

birdy.f
February 28th, 2011, 05:39 PM
y cant i get this ?? send files on device etc??

gandaran
February 28th, 2011, 06:02 PM
when i click on the turn on button..nothing happens!
thats the problem with gnome-bluetooth, most of the times it wont work, install blueman from package manager and use it to turn on bluetooth.

birdy.f
February 28th, 2011, 06:31 PM
i have! and i did..nothing happened..
its the same..pitty.

gandaran
February 28th, 2011, 06:34 PM
i have! and i did..nothing happened..
its the same..pitty.
can you post a screenshot of blueman?

gandaran
February 28th, 2011, 06:40 PM
do you have the bluetooth icon on the panel?

birdy.f
February 28th, 2011, 06:53 PM
yes i had..now its gone!

birdy.f
February 28th, 2011, 06:53 PM
i even took its snap..u saw it!

gandaran
February 28th, 2011, 07:08 PM
i even took its snap..u saw it!
that was the gnome-bluetooth manager!
go to system » preferences, theres two bluetooth launches, one of them is blueman the other is the default gnome-bluetooth.
to get the icon back tick the show icon in gnome-bluetooth window.
use the applications » accessories » capture screenshots utily to take screenshots and post them.
another question, did you get the broadcom wireless driver to work?
read thi (http://freedomandlinux.wordpress.com/2010/02/23/quick-fix-for-broadcom-sta-wifi-bluetooth-in-ubuntu-9-10/)s, maybe there is some conflict between wireless and bluetooth.

birdy.f
March 1st, 2011, 07:24 AM
yes i have blueman n i got my bluetooth icon appearing again..bt still wen i turn it on nothing happens..

birdy.f
March 1st, 2011, 07:28 AM
i hav broadcom B43 installed..

birdy.f
March 1st, 2011, 07:30 AM
i hust have one bluetooth manager wen i go to sys-preferences-bluetooth manager...and wen i click it open error occurs saying Connection to BlueZ failed-Bluez daemon is not running, blueman-manager cannot continue.

birdy.f
March 1st, 2011, 07:42 AM
i dont seem anything wrong with bluez..should i change the version or something.??

birdy.f
March 1st, 2011, 08:33 AM
wen i try this command

sudo /etc/init.d/bluez-utils restart

i get this
sudo: /etc/init.d/bluez-utils: command not found

gandaran
March 1st, 2011, 08:56 AM
i hav broadcom B43 installed..

and wireless is working well?

gandaran
March 1st, 2011, 09:03 AM
also post the output of

lspci

birdy.f
March 1st, 2011, 02:23 PM
in the panel,it shows that wireless is disconnected!
output of
lspci
00:00.0 Host bridge: Intel Corporation Core Processor DRAM Controller (rev 12)
00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 12)
00:16.0 Communication controller: Intel Corporation 5 Series/3400 Series Chipset HECI Controller (rev 06)
00:1a.0 USB Controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 06)
00:1b.0 Audio device: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio (rev 06)
00:1c.0 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 1 (rev 06)
00:1c.1 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 2 (rev 06)
00:1c.5 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 6 (rev 06)
00:1d.0 USB Controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 06)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev a6)
00:1f.0 ISA bridge: Intel Corporation Mobile 5 Series Chipset LPC Interface Controller (rev 06)
00:1f.2 SATA controller: Intel Corporation 5 Series/3400 Series Chipset 4 port SATA AHCI Controller (rev 06)
00:1f.3 SMBus: Intel Corporation 5 Series/3400 Series Chipset SMBus Controller (rev 06)
00:1f.6 Signal processing controller: Intel Corporation 5 Series/3400 Series Chipset Thermal Subsystem (rev 06)
03:00.0 Network controller: Broadcom Corporation BCM4312 802.11b/g LP-PHY (rev 01)
04:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 02)
ff:00.0 Host bridge: Intel Corporation Core Processor QuickPath Architecture Generic Non-core Registers (rev 02)
ff:00.1 Host bridge: Intel Corporation Core Processor QuickPath Architecture System Address Decoder (rev 02)
ff:02.0 Host bridge: Intel Corporation Core Processor QPI Link 0 (rev 02)
ff:02.1 Host bridge: Intel Corporation Core Processor QPI Physical 0 (rev 02)
ff:02.2 Host bridge: Intel Corporation Core Processor Reserved (rev 02)
ff:02.3 Host bridge: Intel Corporation Core Processor Reserved (rev 02)

thaDM
March 13th, 2011, 04:29 PM
I have exactly the same problem as birdy. Any help appreciated.

Dell Inspiron, 10.10.

friend4u
March 14th, 2011, 06:43 AM
Hi Team,
I also got the exactly same problem. Did anybody fixed it? Don't know where to go. I am using Ubuntu 10.10.
Here is my lscpi output:
00:00.0 Host bridge: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT Express Memory Controller Hub (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)
00:1b.0 Audio device: Intel Corporation N10/ICH 7 Family High Definition Audio Controller (rev 01)
00:1c.0 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 1 (rev 01)
00:1c.1 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 2 (rev 01)
00:1c.3 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 4 (rev 01)
00:1d.0 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #1 (rev 01)
00:1d.1 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #2 (rev 01)
00:1d.2 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #3 (rev 01)
00:1d.3 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #4 (rev 01)
00:1d.7 USB Controller: Intel Corporation N10/ICH 7 Family USB2 EHCI Controller (rev 01)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e1)
00:1f.0 ISA bridge: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge (rev 01)
00:1f.2 IDE interface: Intel Corporation 82801GBM/GHM (ICH7 Family) SATA IDE Controller (rev 01)
00:1f.3 SMBus: Intel Corporation N10/ICH 7 Family SMBus Controller (rev 01)
02:00.0 Ethernet controller: Broadcom Corporation BCM4401-B0 100Base-TX (rev 02)
02:01.0 FireWire (IEEE 1394): Ricoh Co Ltd R5C832 IEEE 1394 Controller
02:01.1 SD Host controller: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter (rev 19)
02:01.2 System peripheral: Ricoh Co Ltd R5C592 Memory Stick Bus Host Adapter (rev 0a)
02:01.3 System peripheral: Ricoh Co Ltd xD-Picture Card Controller (rev 05)
0c:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG [Golan] Network Connection (rev 02)
Thanks

thaDM
March 14th, 2011, 10:30 AM
After a lot of searching and reading, it looks like the only current way to fix this is by installing Windows, activate the drivers then install Ubuntu. This appears to be a terrible workaround. Surely the Ubuntuverse could come up with a better solution...? It's times like these that I wish I was a programmer and could actually understand the inner workings of the OS :(

friend4u
March 15th, 2011, 01:59 AM
Hi,
Thanks for you inputs. I did exactly same but still same issue. I down graded to 10.04.02 (from windows vista) and the results are same. When connected to vista bluetooth worked.

thaDM
March 15th, 2011, 10:49 AM
Hi,
Thanks for you inputs. I did exactly same but still same issue. I down graded to 10.04.02 (from windows vista) and the results are same. When connected to vista bluetooth worked.

How on earth did you "downgrade" to 10.04 from Vista? They're different operating systems.

friend4u
March 15th, 2011, 01:05 PM
How on earth did you "downgrade" to 10.04 from Vista? They're different
operating systems.

Sorry for confusion caused. First I installed 10.10. I observed the following problems with that.
1. Static noise caused when recording with Sound recorder. Audocity also caused the same problem but less static.
2. While watching youtube vidieos maximising screen is not streaming video but able to hear audio. I need to go back to non full screen mode.
3. Bluetooth issue.

So I searched forums for bluetooth problem and non worked. I installed vista again and bluetooth enabled. Connected to my headphone and also mobile phone. This time I installed 10.04.2 LTS version. I didn't observe first two problems. But problem 3 still exist.
Thanks

friend4u
March 15th, 2011, 01:15 PM
Here is what system trying to do with that device. Not able to recognize this as buletooth dongle I guess.

usbcore: registered new interface driver hiddev
Mar 14 20:40:31 E1405 kernel: [ 2.157443] ohci1394 0000:02:01.0: PCI INT A -> GSI 19 (level, low) -> IRQ 19
Mar 14 20:40:31 E1405 kernel: [ 2.169268] input: HID 413c:8105 as /devices/pci0000:00/0000:00:1d.1/usb3/3-1/3-1:1.0/input/input7
Mar 14 20:40:31 E1405 kernel: [ 2.169630] generic-usb 0003:413C:8105.0001: input,hidraw0: USB HID v1.11 Keyboard [HID 413c:8105] on usb-0000:00:1d.1-1/input0
Mar 14 20:40:31 E1405 kernel: [ 2.189171] input: HID 413c:8105 as /devices/pci0000:00/0000:00:1d.1/usb3/3-1/3-1:1.1/input/input8
Mar 14 20:40:31 E1405 kernel: [ 2.189679] generic-usb 0003:413C:8105.0002: input,hidraw1: USB HID v1.11 Mouse [HID 413c:8105] on usb-0000:00:1d.1-1/input1
Mar 14 20:40:31 E1405 kernel: [ 2.189750] usbcore: registered new interface driver usbhid

friend4u
March 15th, 2011, 01:17 PM
I guess this should work: but need to try: (Thanks to Topogigi)
So, here comes the workaround:

1) Boot into Vista and download from the Dell support site the last BT 350 driver for Windows XP and unzip it in a folder
2) Find a directory in that folder called "DFU"
3) Find the file called "DFU.exe", right click it and choose "Run as administrator"
4) Wait until the firmware downgrade has finished, then reboot into Vista and you will find that the bluetooth chip is now not recognized. Go to Device manager and manually reinstall the Vista BT driver (don't use the setup.exe provided by the driver pack, simply install it using the "have disk" way and load the .inf file directly from the Vista driver directory).
5) Reboot into Linux. Voilą

friend4u
March 16th, 2011, 02:12 AM
I guess this should work: but need to try: (Thanks to Topogigi)
So, here comes the workaround:

1) Boot into Vista and download from the Dell support site the last BT 350 driver for Windows XP and unzip it in a folder
2) Find a directory in that folder called "DFU"
3) Find the file called "DFU.exe", right click it and choose "Run as administrator"
4) Wait until the firmware downgrade has finished, then reboot into Vista and you will find that the bluetooth chip is now not recognized. Go to Device manager and manually reinstall the Vista BT driver (don't use the setup.exe provided by the driver pack, simply install it using the "have disk" way and load the .inf file directly from the Vista driver directory).
5) Reboot into Linux. Voilą

Thank you guys. My bluetooth working like charm. Here is what I did.
1. boot to windows vista.
2. Remove bluetooth windows profiler.
3. Falsh xp version of drivers using DFUinstaller.exe (found on dell website)
4. Install Ubuntu.