PDA

View Full Version : [ubuntu] How to: Mono sound for Single Speaker Acer Laptops



nolo
February 26th, 2011, 06:52 PM
Hi all,

For everyone running ubuntu on a laptop with a stereo audio adapter but only one built-in speaker, like the Acer Aspire series, here's how you create a mono profile so you can hear both channels through the single built-in speaker:

In Terminal run:

$ pacmd
at the prompt enter:

>>> list-sinksNote your main sink's name so you can inset it into the following code:

>>> load-module module-remap-sink sink_name=mono master=[YOUR MAIN SINK'S NAME] channels=2 channel_map=mono,monoIf you have entered the command correctly, you should be returned to the >>> prompt. Do not exit at this time.

Open Sound Preferences and chose "Remapped Internal Analog Stereo Mono"

You may want to reduce the master volume to prevent audio clipping.

The Mono setting will last as long as pacmd is running in Terminal. To make it permanent, add the command to the end of /etc/pulse/default.pa.

Hope this helps you enjoy ubuntu on your laptop.

nolo

codyv
February 27th, 2011, 10:39 AM
can you please walk me through this step i cant seem to figure it out, i get ikt to work by running pacmd and everything but cant figure out how to edit that file an" :/

"The Mono setting will last as long as pacmd is running in Terminal. To make it permanent, add the command to the end of /etc/pulse/default.pa."

nolo
February 28th, 2011, 03:58 PM
In Terminal enter:

$ sudo gedit /etc/pulse/default.pa

Position your cursor at the end of the file and add the command:

load-module module-remap-sink sink_name=mono master=[YOUR MAIN SINK'S NAME] channels=2 channel_map=mono,mono

Then save the file in gedit.

This will make the mono setting a permanent choice under Sound Preferences.

Good luck.

Nolo

codyv
February 28th, 2011, 08:37 PM
It seems to have worked except for oen thing, if i turn my volume up even remotely high there is major cracking etc. i have to have the volume so low i can barely hear it. any way to fix this?:confused:

codyv
March 1st, 2011, 12:36 AM
got never mind thanks so much

codyv
March 1st, 2011, 04:21 AM
its happening again. any way to fix the crackling?

Sylos
December 7th, 2011, 01:56 PM
Hello.

I have a packard bell with a similar set up - single speaker.

I have tried following the guide above but it has had no effect on the sound - im still only getting one channel of audio.

Can anyone offer any guidance?


Cheers

EDIT: Got it working but like others I have terrible crackling and popping. I guess nobody has a fix for that?

Lemagex
October 25th, 2012, 09:05 AM
I know this is an old thread, but I've had this problem too. these instructions are still valid in 12.10 and as for the "crackling" people still have after using these settings, my solution is to switch back to the NON remapped stream in Gnome sound settings, turn the volume on that up to say 105% then switch back to the remapped stream and turn the volume up just a bit or lower, it allows you to have louder volume before it starts to crack. :)

wildmanne39
October 26th, 2012, 01:44 AM
Thanks for sharing and please do not post in threads that have not had activity for a year or longer, since this is an old thread it has been closed.