PDA

View Full Version : [ubuntu] nvidia x settings revertting to 800x600



tempmike
February 26th, 2011, 05:34 AM
I know I need to be running gksudo to save the settings and have done so to save my higher resolution. But after every reboot my display is set back to the default.

I'm running 10.04. Let me know what other information might be helpful in fixing this.

acrazyplayer
February 27th, 2011, 12:29 AM
just some questions.

what gfx card do you have? what driver are you using? does the maximum resolution ever get applied?

tempmike
March 2nd, 2011, 04:32 AM
sorry for the slow reply. I can go into the settings and change to a higher resolution, but when I restart my system (after saving the changes to the /etc/X11/xorg.conf file) the resolution reverts to 800x600

The card is an ASUS GTX460.
Drivers are NVIDIA 260.19.36 (which i believe are the most recent)

When I check the system - admin - hardware drivers the window says "No proprietary drivers are in use on this system"

And one bit of information which may help: when I installed the 10.04 I was using the integrated graphics on my motherboard which is the ATI Radeon HD4290 GPU. So I had the drivers for that installed and somehow managed to uninstall that with help from some forum post somewhere.


Here's what the xorg.conf file previews as:
# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings: version 260.19.36 (buildmeister@swio-display-x86-rhel47-01.nvidia.com) Tue Jan 18 17:15:10 PST 2011

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
Option "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"
# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"
# HorizSync source: edid, VertRefresh source: edid
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Ancor Communications Inc ASUS VH242H"
HorizSync 30.0 - 85.0
VertRefresh 55.0 - 75.0
Option "DPMS"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce GTX 460"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "TwinView" "0"
Option "metamodes" "1920x1080_60 +0+0; 1920x1080 +0+0; nvidia-auto-select +0+0"
SubSection "Display"
Depth 24
EndSubSection
EndSection

acrazyplayer
March 2nd, 2011, 04:18 PM
I'm thinkin the reason why it keeps reverting is because of the driver you had for the on board graphics.

it sounds like maybe something is still left over from that install and I bet when booting that Ubuntu is getting conflicting information or even it just takes what it sees first and that is some older left behind file.

when you install your driver from nvidia website the hardware scanner will say that there are no drivers available for your system, at least it didnt for me either and I think its better that way unless some would get confused.

The way to fix it sounds like it could be difficult but maybe try searching for any leftover ati driver files, just use the file finder located in applications/accessories and choose to add "show hidden and back up files" to your search query.

tempmike
March 2nd, 2011, 07:42 PM
Thanks, I'll give this a try this evening.