View Full Version : [xubuntu] can only use use terminal

February 24th, 2011, 04:13 PM
Hi, I tried to change from gdm to xdm, but now It won't work to start, and since I don't have an X-environment I can't connect to internet (this is my game computer i'm on right now...)
so I hope that you guys could help me.

first I tried to switch so that gdm opens with fluxbox, that worked brilliantly.
by using this script in both .xinitrc and .xsession:

#! /bin/bash
gdm session &&
exec fluxbox

but then I thinked: but I want to play minecraftwhen I'm travelling, but I need more power to do that...

so I tried to install and use xdm as default, but then it didn't work to startup, so I tried this:
change in .xinitrc and .xsession:

#! /bin/bash
xdm session &&
exec fluxbox

but it still does not work. so I can only terminal on my Liux computer...

So can anyone help me with this?

February 25th, 2011, 12:34 AM
First remove those entries from the files, since it is imo an unusual way to choose a default DE. You can use the "nano" editor for that, it's fairly intuitive compared to the other command line editors:

nano .xinitrcThen the other.

If you restart after this, XDM should come up with the usual login options, there you can choose a "Session", after entering/clicking your name, and those choice should be remembered the next time you login. No need to manually modify any files then.

If you use autologin, just logout after the autologin to get those options. Alternatively you can specify your default DE manually in "~.dmrc".

February 25th, 2011, 01:38 AM
I tried to do what told me to, nut it still does not start up, I even tried to remove those files, but it just did not work

February 25th, 2011, 01:57 AM
Then try:

sudo dpkg-reconfigure xdm
or "gdm" if that doesn't work.

February 25th, 2011, 10:08 AM
Hi, i've tried what you told, but I only get this message: system start/stop links for /etc/init.d/xdm already exist.

about a week ago I tried to reinstall gdm by typing;

sudo apt-get remove gdm
sudo apt-get install gdm

I can't install it again since I need to download 741 kb of archives

February 25th, 2011, 08:03 PM
Is "gdm" then installed currently?

dpkg -l |grep gdm
If so, then try the mentioned command.

February 26th, 2011, 01:01 PM
As I said, Can't reinstall gdm, so it is not installed....

February 26th, 2011, 07:42 PM
Try to get to the console with network access by following the first steps of this guide:

You could also download it from here:

and install it with "dpkg":

sudo dpkg -i package_name.deb
If you issue the command from the "root shell prompt", then run it without "sudo".

February 26th, 2011, 10:17 PM
thanks alot, now I can finally use my computer wise again. because now it works as it were supposed to work - with X-server up and running

but do you guys know how to switch to XDM without this to happen?

February 26th, 2011, 11:22 PM
sorry for dubbel post, but I must tell U this

it worked fine, that will say, until I reboot computer, because then I get an init error;

init: ureadahead main process (51) terminated with status (5)

and then it tries to boot, but it can't since it having massive amounts of problems with apparmor, and then it still want to start xdm, but it fail with doing so, so it freezes, (I can only have teminals now, again...)

shall I write what it says (only the thing I can see) on the screen when it freezes?

February 27th, 2011, 12:18 AM
A log would be great, if you can pull it out there: "/var/log/messages".

Please post it in code-tags, the #-button in the editor.

But it worked before, after installing GDM?