PDA

View Full Version : [ubuntu] 10.10 64-bit - After I re-login, the Gnome theming gets disable



mecablaze
February 23rd, 2011, 03:05 PM
I am on Ubuntu 10.10 64-bit version (Gnome). I am running an NVIDIA GeForce 9800 GT graphics card with the NVIDIA proprietary drivers. I have dual screens running at 1920x1080.

I am dual booting with Windows 7 but I don't think that should make a difference (BURG is my bootloader).

When I first boot up into Ubuntu and log in, my desktop looks just great, like this:

http://i.imgur.com/vcQiY.png

But if I log out then log back in, my theme reverts to a grey blockish theme that seems to be reserved so weak video cards or something like that. I'm somewhat new to Ubuntu desktop so bear with me.

This is what it looks like:

http://i.imgur.com/tvvXp.png

Any clues on what could be going on here?

3Miro
February 23rd, 2011, 05:35 PM
The theme changed. Go to System -> Prefs -> Appearance and pick any theme that you like (you can use the software center to install even more themes).

mecablaze
February 23rd, 2011, 10:08 PM
I already tried that. The same theme is selected, but it displays in that grey bar theme.

Krytarik
February 23rd, 2011, 10:26 PM
There is a common issue currently regarding the handling of themes, apparently only in Maverick:
http://ubuntuforums.org/showthread.php?t=1575703

I believe there is no difference in the default themes regarding the video capabilities. But the "Raleigh" theme which you were seeing is the default fallback theme.

An UF user recently brought up another interesting "solution", just to rename the themes.;-) I guess that could be an easy solution for all experiencing those issue, and since the theme packages apparently never get updated after the release this change should be permanent. To do so you have to change not only the directory names, but also the names in the respective "index.theme" file in the theme's root directory, you have to open it from within the text-editor.

rondeth
February 24th, 2011, 05:17 PM
This happens to me occasionally as well. The controls are unthemed, the icons reset to default set, etc.

A solution I found (somewhere on this board) is to do the following:

1) Use system monitor (or whatever) to kill gnome-settings-daemon
2) Open Appearance applet (styling should come back to theme which had been set)
3) Kill nautilus to restart (brings back icons)

That works for me, anyway. YMMV.

Thomas Mann
April 6th, 2011, 06:00 PM
I tried steps sugested by rondeth:http://ubuntuforums.org/images/editor/menupop.gif
1) Use system monitor (or whatever) to kill gnome-settings-daemon
2) Open Appearance applet (styling should come back to theme which had been set)
3) Kill nautilus to restart (brings back icons)
& that worked for me... however I still looking for a 'permanent' solution...does anybody else have more ideas? :confused:

https://picasaweb.google.com/lh/webUpload?uname=117444586068677827411&aid=5592514898695293345

Krytarik
April 6th, 2011, 06:58 PM
Please see these earlier posts about more permanent workarounds:
http://ubuntuforums.org/showthread.php?p=10634531#post10634531
http://ubuntuforums.org/showthread.php?p=10642545#post10642545

Greetings.

Thomas Mann
April 7th, 2011, 10:21 AM
Can anybody explain this:
:~$ Unable to find a synaptics device.
The program 'gsd-locate-pointer' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadAccess (attempt to access private resource denied)'.
(Details: serial 124 error_code 10 request_code 33 minor_code 0)
(Note to programmers: normally, X errors are reported asynchronously;
that is, you will receive the error a while after causing it.
To debug your program, run it with the --sync command line
option to change this behavior. You can then get a meaningful
backtrace from your debugger if you break on the gdk_x_error() function.)

Krytarik
April 7th, 2011, 05:16 PM
Can anybody explain this:
:~$ Unable to find a synaptics device.
The program 'gsd-locate-pointer' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadAccess (attempt to access private resource denied)'.
(Details: serial 124 error_code 10 request_code 33 minor_code 0)
(Note to programmers: normally, X errors are reported asynchronously;
that is, you will receive the error a while after causing it.
To debug your program, run it with the --sync command line
option to change this behavior. You can then get a meaningful
backtrace from your debugger if you break on the gdk_x_error() function.)
Did you run "gnome-settings-daemon" as root, with "sudo" or "gksudo" respectively?
You shouldn't do that, because it tries to apply root's settings to your running session then.

If you didn't do that, then just ignore the error messages, because they aren't reflecting major issues, and gnome-settings-daemon should run fine regardless of them.