PDA

View Full Version : [ubuntu] Wifi suddenly stopped working



Danicek
February 21st, 2011, 06:29 PM
Hello,

So being first time Linux user, I've installed Ubuntu one my laptop (Compaq Presario CQ60). Everything worked great right out of the box for few weeks. Then suddenly wifi stopped working. I'm not aware of any changes or anything I would do that could cause this.

I'm running release 10.10.

iwconfig says:

lo no wireless extensions.
eth0 no wireless extensions.
wlan0 IEEE 802.11bg ESSID:off/any
Mode: Managed Access point: Not-Associated Tx-Power=off
Retry long limit: 7 RTS thr: off Fragment thr: off
Encryption key:off
Power Management: off

The laptop has dedicated wifi on/off button. This button indicates wifi is on. However pressing it has no impact (as it used to under Windows) and no effect on iwconfig output.

Other laptops are able to use the wifi router, so it is not problem with the router.

I've tried few things I could find on this forums but with no luck.

Any help would be appreciated.

Danicek
February 21st, 2011, 07:42 PM
Ok, so

rfkill unblock all

fixed the issue.

Why? What does this command do?

bapoumba
February 21st, 2011, 08:05 PM
http://www1.ubuntuforums.org/showthread.php?p=10409652
Maybe ?