View Full Version : [ubuntu] Compiz effects initially jerky

February 16th, 2011, 03:32 PM
Hey everyone,

I'm loving my compiz effects on my desktop. Have changed it to run at 60Hz and looks lovely.

One thing I've noticed is that the effects are jerky at first if they haven't been used in a while, but then smoothen in a second or two. Is this because it has to load the background or something?

I have a desktop cylinder with an animated skydome. When I start rotating it it's jerky, but once I've rotated it for about 1 second it goes really smooth. Same with window maximize/minimise effects.

How can I make it smooth from the start?


February 16th, 2011, 03:34 PM
this is just a guess... how "nice" is the compiz process?

February 16th, 2011, 03:43 PM
this is just a guess... how "nice" is the compiz process?

I don't know what you mean. Is there a "niceness" setting in CCSM? In Appearance dialog it's set to Custom (because I've got simple-ccsm installed).

February 16th, 2011, 03:47 PM

and type in:

then click on "processes" and there will be a column that says "nice"

February 16th, 2011, 03:51 PM
Ah! It's Nice is 0.

February 16th, 2011, 06:09 PM
Right-click on the compiz process and select "Change Priority...". Then drag the slider to the left until the nice is -5. Then click "Change Priority".

February 16th, 2011, 09:04 PM
I have noticed that, too. I run Ubuntu on a notebook with C2D cpu and nvidia graphics card. The machine attempts to save power by downclocking both the CPU and the GPU when it's idle.

When compiz effects are on, it usually takes a second or two for the machine to detect it and switch the GPU to higher frequency. That's what causes the initial jerkiness. After that, everything is smooth until effects stops. When the machine detects that no effects are active, the GPU is no longer required to do any hard work and gets downclocked.

System - Administration - NVIDIA X Server Settings - Powermizer shows the changes in frequency. You can also use it to force "prefer maximum performance" instead of "adaptive" mode, but that will probably drain your battery faster and generated excess heat. But your transitions will be smoother. :)

February 17th, 2011, 10:20 AM
That seems to have fixed it! Thanks.

February 17th, 2011, 05:29 PM
Glad it's working!

February 17th, 2011, 05:46 PM
It's not quite working. This setting resets on every reboot. Thread about it here: http://ubuntuforums.org/showthread.php?p=10467693

February 17th, 2011, 09:46 PM
I have done a bit of searching and it seem you would have to edit xorg.conf and append a line there. But I haven't tried it.

How-to video:


Some more information:


Explanation of parameters (read this first before you edit anything!):


Configuration examples
Look at four popular 'RegistryDwords' option values:

* on battery - max power saving, on AC - max performance

"PowerMizerEnable=0x1; PerfLevelSrc=0x2222; PowerMizerDefault=0x3; PowerMizerDefaultAC=0x1"

* on battery - max power saving, on AC - adaptive strategy (my favorite)

"PowerMizerEnable=0x1; PerfLevelSrc=0x2233; PowerMizerDefault=0x3"

* on battery - adaptive strategy, on AC - max performance

"PowerMizerEnable=0x1; PerfLevelSrc=0x3322; PowerMizerDefaultAC=0x1"

* adaptive strategy for any power source

"PowerMizerEnable=0x1; PerfLevelSrc=0x3333"

February 24th, 2011, 12:09 PM
Works for me. I just added:
Option "NoLogo" "True"
Option "RegistryDWords" "PowerMizerEnable=0x1; PerfLevelSrc=0x2222; PowerMizerDefault=0x3; PowerMizerDefaultAC=0x1"into the "Device" section and it's fixed it. The setting util still says it's in Adaptive mode though, but I'm pretty sure it's not.