PDA

View Full Version : [SOLVED] ubuntu default runlevel



ubun2warrior
February 16th, 2011, 08:24 AM
hi

i do not want the graphical boot in ubuntu and want to change my default runlevel to 3(i suppose that is correct...)

i am using ubuntu 10.10.

i have tried /etc/inittab its not working here.

plz tell me how should i do it.

rgds
ubun2warrior

inobe
February 16th, 2011, 09:43 AM
more specific way but it's in there.

https://help.ubuntu.com/community/BootOptions

ubun2warrior
February 16th, 2011, 10:01 AM
hi

i want a more simple way of doing this. all i want is that the default runlevel is 3 and if i want to revert back i can do so easily.
actually i don't want the ubuntu splash screen and the ubuntu log in screen.

rgds

sisco311
February 16th, 2011, 10:18 AM
Ubuntu uses Upstart (http://upstart.ubuntu.com/). Runlevels are still emulated, but just like in Debian, by default, runlevels 2,3,4, and 5 are the same.

If you want to disable the display manager, then use the text kernel parameter. Edit the file /etc/default/grub and replace the line GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" with GRUB_CMDLINE_LINUX_DEFAULT="text" and generate a new Grub config file:

sudo update-grub

ubun2warrior
February 22nd, 2011, 06:09 PM
Ubuntu uses Upstart (http://upstart.ubuntu.com/). Runlevels are still emulated, but just like in Debian, by default, runlevels 2,3,4, and 5 are the same.

If you want to disable the display manager, then use the text kernel parameter. Edit the file /etc/default/grub and replace the line GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" with GRUB_CMDLINE_LINUX_DEFAULT="text" and generate a new Grub config file:

sudo update-grub

hi

thanks a lot this just did what i wanted !!!

rgds