View Full Version : [gnome] 9.04 - Keyboard layout switches by itself when opening a new window.

February 12th, 2011, 08:37 PM
I've got:

9.04 Jaunty Jackalope 64 bit, running compiz (but that shouldn't matter, should it?)

In Keyboard Preferences:

Separate layout for each window unchecked (and exactly as I want it)

3 keyboard layouts, in the order I have now:
1) Italian
2) Dvorak International
3) Left Handed Dvorak

My problem is (and this problem can be repeated) that whenever I open up a new window, usually big programs like Azureus, Firefox, OpenOffice, Adobe Reader and Opera, the keyboard layout switches straight to Italian, regardless of the layout I had previously active. Even VLC does it, but it does it only every second time I open it. Strangely enough, Totem doesn't do it at all.

This is more than annoying. I just don't know why nobody else has experienced this before. Maybe it's not that big an annoyance...

Anyway, I've trying fiddling around with various combinations of
Separate layout for each window unchecked or checked
Apply System-Wide
and rearranging the layouts.

Basically it will switch to the uppermost layout found in the Selected layouts: list whenever I open a new window of the above-mentioned programs, among others.

Even giving me a few pointers, like which log files to check out, would be much appreciated. Just please don't tell me stuff like "switch to a different version, it works better in 10.04 or 10.10" - I'd rather figure out the problems in this one than deal with a whole slew of new bugs in another version.

February 12th, 2011, 08:40 PM
Welcome to the forums. Unfortunately my advice is exactly what you don't want to hear: 9.04 reached its "end of life" last year and is no longer supported in any way. If there is a bug in how 9.04 handles keyboard layout, it will never be fixed.

Certainly it is worth 20 minutes of your time to test-drive a Live CD of the current release to see if the problem has been fixed in the almost 2 years since 9.04 was released? :)

Copper Bezel
February 12th, 2011, 10:31 PM
I don't think it's a version thing. I remember experiencing this on 9.10, and I'm pretty certain I worked it out, but I don't remember the details aside from pulling my hair a lot. Of course he'd be better off on a supported version, but I'm not 100% certain that the problem wouldn't reappear.

February 20th, 2011, 01:19 AM
I have to admit, 10.04 LTS is pretty good, not so many bugs to figure out. I have it now on my laptop, and I should blame myself for not wanting to go through the procedure of backing up my stuff on this computer before taking the leap to 10.04.

Thanks anyway

February 20th, 2011, 02:10 AM
A wrote little tutorial recently to work around another issue of the layout switcher, you could use it to avoid an immediate version switch:

Basically it's that way: if there is no other layout specified at the same time, it cannot falsely switch to it. ;)


June 8th, 2011, 09:41 AM
Alright, as you can see from the reply, I've just figured out it's Compiz. I simply stumbled upon this when doing my regular switch to Metacity for remote desktop access, because as some of you may already know, Compiz doesn't display well through a remote desktop viewer.

So, I know this problem doesn't happen when Metacity's running. That said, it could either be Compiz or the Emerald that I've added to it for the oh-so-sexy window decorations and transparencies.

I really don't want to lose this functionality, because I've set Compiz to actually work for me, not just be a looker. Then again, keyboard layout switching is imperative, because I'm a custom Italian Dvorak guy and my wife's still on Italian QWERTY. And nothing's more irritating than accidentally hitting the wrong hotkey while saving files or typing gibberish while searching text in a word processor, simply because the computer felt like doing me a favour I didn't want done.

Any pointers on Compiz relating to keyboard layout? I've done a few Googly searches, but found nothing useful yet.

I seriously doubt this will be fixed in a new version, considering not many people have addressed this.

June 11th, 2011, 02:00 PM
Okay, I know for sure it's Compiz. Even with Emerald disabled in every which way, I still get the problem.