View Full Version : basic Python problem

February 10th, 2011, 05:17 AM
Hi. I'm fairly new to Linux and just learning Python. I've hit a bit of a snag and I honestly have no idea where to even begin to try to fix it. The issue is pretty straight forward. I have created a new module, just a stupid test module from a book, and I am trying to install it in my local Python. Building the distribution went fine, but when I tried to install I was thrown an error. Hoping maybe someone here can tell me what I have done wrong.

I was in the terminal in the folder of the module ( having just made the distribution ), and I typed the following:

python3 setup.py install

It did most everything it was supposed to do, but at the end it spit out this:

copying build/lib.linux-i686-3.1/newmod.py -> /usr/local/lib/python3.1/dist-packages
error: /usr/local/lib/python3.1/dist-packages/newmod.py: Permission denied

Where have I gone wrong?

February 10th, 2011, 05:28 AM

February 10th, 2011, 06:21 AM
my guess is that you forgot to put sudo in front of the command.

You should post how you resolved the problem, and then mark the thread as solved, to help others that may run into a similar problem :)