View Full Version : [SOLVED] can't install phpMyAdmin

February 8th, 2011, 03:43 AM
hi, in an effort to fix my recent mysqld.sock file woes, i corrupted phpMyAdmin. I have reviewed this page:

i was never able to install it from either Synaptic or from a command line. i kept getting this error:
Failed to fetch http://archive.ubuntu.com/ubuntu/pool/main/p/php5/php5-mysql_5.3.2-1ubuntu4.5_i386.deb
404 Not Found [IP: 80]

i even tried apt-get with the remove option set. i still got that "failed to fetch" error afterwards.

from the page above, this command executed:
sudo svn checkout https://phpmyadmin.svn.sourceforge.net/svnroot/phpmyadmin/tags/STABLE/phpMyAdmin phpMyAdmin

unfortunately, i have nothing in this folder:

i have deleted it and recreated it, then set permissions on the folder:
sudo chmod o+rw config

when i try to look at the documention, i see nothing about troubleshooting:

when i try to run the setup script I get a 404:

setup.php has this permission:

does anyone have any suggestions? thanks.

February 8th, 2011, 03:52 AM
What version of Ubuntu are you running?

February 8th, 2011, 01:10 PM
Ubuntu 10.04. thanks.

February 8th, 2011, 05:57 PM
Be sure to update the index before trying to install it:

sudo apt-get update && sudo apt-get install phpmyadmin

February 9th, 2011, 01:54 AM
Charles, thanks!!

i learned how to solve it, what was wrong. thanks again!

February 9th, 2011, 02:30 AM
Glad you got it fixed, don't forget to mark the thread as solved from thread tools.