View Full Version : [ubuntu] Cannot play audio CD from VLC

February 8th, 2011, 01:01 AM
It saying that cannot open "cdda:///dev/sr0", how can I check for more information?

February 8th, 2011, 02:17 AM
You might want to post what version of vlc and what release of ubuntu.

Meanwhile ck. and see if the drive w/ the audio cd is actually /dev/sr0

sudo lshw -C disk
look in the *-cdrom: section(s)

February 8th, 2011, 05:56 PM
Thanks a lot, I am using ubuntu 10.10 and my vlc version is 1.1.4

Here is the output of "sudo lshw -C disk"

description: DVD-RAM writer
product: iHAS120 6
vendor: ATAPI
physical id: 0.0.0
bus info: scsi@2:0.0.0
logical name: /dev/cdrom1
logical name: /dev/cdrw1
logical name: /dev/dvd1
logical name: /dev/dvdrw1
logical name: /dev/scd0
logical name: /dev/sr0
version: 7L04
capabilities: removable audio cd-r cd-rw dvd dvd-r dvd-ram
configuration: ansiversion=5 status=nodisc

And my VLC showing the error:

[0x8790204] cdda access error: could not read TOCHDR
[0x8790204] cdda access error: no audio tracks found
[0xb7000694] main input error: open of `cdda:///dev/scd1' failed: (null)

February 8th, 2011, 06:56 PM
You're showing some conflicting info - in first post

t saying that cannot open "cdda:///dev/sr0"
Then last post

0xb7000694] main input error: open of `cdda:///dev/scd1' failed: (null)
Do you have 1 or 2 drives? (assuming 1

When you put an audio cd in that drive does an icon show up on Desktop?

Assuming it does try any of these

put an audio cd in and hold the shift button down till you get a pop up, in the drop down choose vlc

Open vlc > Tools > Preferences > Input and Codecs, set the optical device to /dev/sr0 and save

From a terminal w/ audio cd in the drive

vlc cdda:///dev/sr0

February 8th, 2011, 08:17 PM
Sorry it is /dev/sr0, I just give a try to /dev/sr1 and it show same error

Thanks for suggestion but I still see that error.... Maybe my DVD drive have problem? The CD is perfectly ok

February 8th, 2011, 08:37 PM
When you insert the audio cd does an icon show up on the Desktop?
The sudo lshw ... you posted before indicated no disc in the drive

configuration: ansiversion=5 status=nodisc
When an audio cd is in the drive the lshw ... command should show 'ready'
Ex. here, audio cd in my second drive

description: DVD reader
product: DVD-ROM GDR8164B
vendor: HL-DT-ST
physical id: 1
bus info: scsi@1:0.0.0
logical name: /dev/cdrom
logical name: /dev/dvd
logical name: /dev/scd1
logical name: /dev/sr1
version: 0L06
capabilities: removable audio dvd
configuration: ansiversion=5 status=ready

Bit of a longshot - search gvfs in synaptic, completely remove and then re-install the gvfs-backend package

Maybe my DVD drive have problem?
Always a possibility

February 9th, 2011, 07:08 PM
I just try with all my CDs, some work and some doesn't, but they are all worked in Windows, look like somehow my DVD-RW more sensitive to bad CD disc