View Full Version : [gnome] rememberrunning applications

February 7th, 2011, 09:25 AM
I would like that the windows I am working on are reopened automatically at login, so I checked

System -> Preferences -> Startup Applications -> Options Tab -> Check Automatically remember running applications when logging out.

It works but, unfortunately, sometimes windows are reopened in different workspaces. I have six workspaces and I usually keep a lot of windows opened, so rearranging them takes long.

Is there a way to ensure that windows are reopened in the same workspace?

February 8th, 2011, 02:56 AM
You could generaly use the "Place Windows" plugin of Compiz to stick your apps to specific workspaces, this should also fix your current issue.

"System -> Preferences -> CompizConfig Settings Manager -> Window Management -> Place Windows"

February 8th, 2011, 07:23 PM
Thanks for the hint. It actually solves the problem. However, having a NVIDIA card, I have to disable Compiz because of a very annoying bug - when you open more than n windows, with n > 12, more or less, new windows opened are completely black. Disabling Compiz make it possible to open up to 15 windows. But I will probalby change video card soon...

February 8th, 2011, 07:36 PM
Hmm.. sounds like your videocard is running out of videoram, with 6 workspaces and a dozen apps? Seems kind of quick though. Is this a really old videocard with very low amount of videoram? If its onboard video, you might want to check your bios if you can allocate more system RAM to the videocard.

February 8th, 2011, 10:59 PM
The video card is not that old...I think. It's a NV 44 (Geforce 6500). I read that there was a bug in the Nvidia proprietary driver causing the black windows that was removed in the latest versions. Actually, I complained about that in the forum but it seems I am the only one suffering from this problem now.

February 8th, 2011, 11:07 PM
How about upgrading to the latest driver package provided by Ubuntu-X-Swat?:

February 9th, 2011, 09:49 PM
I'll give it a try, thanks