PDA

View Full Version : [ubuntu] Nvidia driver 260.19.36 59.95 Hz DFP refresh rate??



Harrier
February 5th, 2011, 02:38 PM
Hi

I am using Ubuntu Lucid 10.04.

I a 26" digital TFT display (NEC LCD2690WUXi2) hooked up to an Nvidia GeForce 210 GPU via DVI.

The proprietary Nvidia driver appears to run OK. I've installed the VDPAU version of XBMC from a PPA. I am not sure - but I think VDPAU appears to be working for DVD playback (just by looking at the utilization of the dual core CPU)... Not really sure how to check this properly (the vdpauinfo command appears to have the correct output).

However shouldn't the display run at a 60Hz refresh?? It starts up at 59.95Hz and I can't change it to anything different in the Nvidia X Server Settings widget. I have noticed a slight glitch with XBMC DVD playback (flickering reoccurring in the middle of the frame) - vertical framelock is enabled in the settings... What CPU utilisation should I expect with a dual-core Athlon 64 @2.2Ghz (2x512Kb cache)? Perhaps I should rip the DVD to my HD first (rather than playing it back straight from my LiteOn DVD re-writer)?

Is there a problem or is it all just in my imagination?? :-({|=

Thanks
Paul

uname --all:

Linux pauls-desktop 2.6.37-12-generic-pae #26~lucid1-Ubuntu SMP Wed Jan 5 22:54:38 UTC 2011 i686 GNU/Linux
xorg.conf:

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings: version 260.19.29 (buildd@rosehip) Thu Dec 23 06:12:39 UTC 2010

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 260.19.29 (buildmeister@swio-display-x86-rhel47-08.nvidia.com) Wed Dec 8 12:28:55 PST 2010

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
Option "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"

# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "NEC"
ModelName "LCD2690WUXi2"
HorizSync 31.0 - 92.0
VertRefresh 50.0 - 85.0
Option "DPMS"
EndSection

Section "Device"
Identifier "Device0"
Option "TwinView" "FALSE"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce 210"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "metamodes" "1920x1200 +0+0"
SubSection "Display"
Depth 24
EndSubSection
EndSection
/proc/cpuinfo:

processor : 0
vendor_id : AuthenticAMD
cpu family : 15
model : 35
model name : AMD Athlon(tm) 64 X2 Dual Core Processor 4200+
stepping : 2
cpu MHz : 2209.886
cache size : 512 KB
physical id : 0
siblings : 2
core id : 0
cpu cores : 2
apicid : 0
initial apicid : 0
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 1
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt lm 3dnowext 3dnow pni lahf_lm cmp_legacy
bogomips : 4419.77
clflush size : 64
cache_alignment : 64
address sizes : 40 bits physical, 48 bits virtual
power management: ts fid vid ttp

processor : 1
vendor_id : AuthenticAMD
cpu family : 15
model : 35
model name : AMD Athlon(tm) 64 X2 Dual Core Processor 4200+
stepping : 2
cpu MHz : 2209.886
cache size : 512 KB
physical id : 0
siblings : 2
core id : 1
cpu cores : 2
apicid : 1
initial apicid : 1
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 1
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt lm 3dnowext 3dnow pni lahf_lm cmp_legacy
bogomips : 4420.67
clflush size : 64
cache_alignment : 64
address sizes : 40 bits physical, 48 bits virtual
power management: ts fid vid ttp

Harrier
February 7th, 2011, 06:46 PM
Bump ):p

BicyclerBoy
February 8th, 2011, 12:18 AM
NTSC colour is 59.94 field rate & not 60Hz.

What vdpau settings do you have configured in XBMC ?
The GT210 is not fast enough for advanced x2 de-interlacing so check you have not got playback profile set to max vdpau settings.
AFAIK it is not fast enough for some other feature set C features.
GT220 is the minimum recommended.

Do you have medibuntu repos ? ubuntu-restricted-extras libdvdcss etc ?

Have you read the ubuntu webpage about DVD playback ?
https://help.ubuntu.com/community/Medibuntu