PDA

View Full Version : [SOLVED] Error when Installing or Removing Sofware



j_arshad
February 5th, 2011, 05:46 AM
Hi,

Ive installed Ubuntu 10.10 on my netbook. My system has Broadcom PCI wireless card - BCM 4312 with PCI ID 14e4:04B5. When I installed the OS, I got a message that the system did not have the firmware for the wireless card and wanted me to download one from web. I first tried installing b43 kernel driver and it did not work. Then I tried the STA hybrid driver and got it working. Now, everytime I install or remove any application, I get a message dpkg: error processing firmware-b43-installer (--configure):
subprocess installed post-installation script returned error exit status 1 and though the application that Iḿ trying to install or remove finally gets installed/removed, but still pops up the message.

I need to know why this error pops and how to get rid of it.

Regards,
Arshad

sikander3786
February 5th, 2011, 09:27 AM
Welcome to the forums :-)

From Applications > Accessories > Terminal:


sudo apt-get remove --purge firmware-b43-installer


sudo dpkg --configure -a


sudo apt-get install -f


sudo apt-get update && sudo apt-get upgrade

Please post the errors if any, straight in your post instead of attaching a .txt file.

j_arshad
February 6th, 2011, 03:29 AM
Hi Sikander,

Thanks for your response.

I tried the codes given by you. When I try the code,

sudo apt-get upgrade

I get the following message:

Err http://ubuntu.oss.eznetsols.org/ubuntu/ maverick-updates/main libebook1.2-9 i386 2.30.3-2ubuntu2.1
The HTTP server sent an invalid Content-Range header
Err http://ubuntu.oss.eznetsols.org/ubuntu/ maverick-updates/main nautilus-sendto-empathy i386 2.32.1-0ubuntu1.1
Bad header line
Failed to fetch http://ubuntu.oss.eznetsols.org/ubuntu/pool/main/e/evolution-data-server/libebook1.2-9_2.30.3-2ubuntu2.1_i386.deb The HTTP server sent an invalid Content-Range header
Failed to fetch http://ubuntu.oss.eznetsols.org/ubuntu/pool/main/e/empathy/nautilus-sendto-empathy_2.32.1-0ubuntu1.1_i386.deb Bad header line
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

Any idea what should be done?

Thanks,
Arshad

sikander3786
February 6th, 2011, 10:19 AM
Change your server to Main from Software Center > Edit > Software Sources and try again.

j_arshad
February 6th, 2011, 03:06 PM
It worked.Thanks.