View Full Version : [SOLVED] Luatex with wrong zlib version

February 3rd, 2011, 05:46 PM
I'm trying to install latex. (I'm using the packages tex-common, tex-base and tex-bin)
However, installation fails.
When I dug up the error log, I found out that the error was in this command (and others like it):

$luatex -ini -jobname=luatex -progname=luatex luatex.ini

PANIC: unprotected error in call to Lua API (zlib library version does not match - header:, library: 1.2.5)

What should I do?
I already tried downgrading my zlib but that didn't work.
Should I remove zlib and try to install or is there a way to remove the check from luatex?

Any help would be greatly appreciated - I have a few papers to turn in ;)

February 3rd, 2011, 06:13 PM
Are you running Ubuntu 10.04.1? Depending on what Ubuntu you have installed your zlib1g version would be as such:

Ubuntu 8.04.4 (hardy) -
Ubuntu 9.10 (karmic) -
Ubuntu 10.04.1 (lucid) -
Ubuntu 10.10 (maverick) -

Seems you have the latest release installed from the website[1]. You should go back to the version supplied by hardy, karmic, or lucid.

[1] http://www.zlib.net/

February 3rd, 2011, 06:31 PM
I just apt-get removed 'zlib-bin'.
When I try to remove zlib1g, I get a huge list of packages that I don't really wanna remove.
How do I install zlib-bin-

February 3rd, 2011, 08:15 PM
Oh, by the way, I am using 10.04.1 LTS

February 4th, 2011, 11:21 AM

January 21st, 2012, 07:26 PM
I just gave it another try. I replaced my zlib with the PPA here [https://launchpad.net/ubuntu/+source/zlib] and texlive installed successfully.

January 23rd, 2013, 08:25 PM
I am having the same issue and have the expected zlib libraries installed:
ii zlib1g 1: compression library - runtime
ii zlib1g-dev 1: compression library - development

Not sure how to solve this since there doesn't seem to be any problems with the installed versions - the system is updated to latest version of all packages for 10.04.4 LTS.