View Full Version : [ubuntu] 10.10 does not load after updates. "No init found."

January 18th, 2011, 08:27 PM

I updated ubuntu (10.10) today after not doing so in a while and there was an error after it had done most of the updates. However, foolishly, I payed little attention to this and i rebooted my computer for the updates to take effect and received the error:

No init found. Try passing init= bootarg

I received this error no matter which kernel I tried...

After researching i downloaded and installed the iso onto USB stick. This however also failed because for some reason it did not know the location of vmlinuz and initrd.lz....

However, when i inserted the code so it would know the location of these files it loads somewhat but eventually comes up with the same error. Can anyone help?

Thank you.

March 5th, 2011, 10:09 PM

I guess this is too late a solution for you, but for anyone else facing this problem (the first problem at least, not sure about the usb flavour of the problem), this website has the steps on how to fix it :-


Basically boot with the live cd, then run an fsck on your drive. Then when you reboot it should be fixed.

But, make sure you are using the 10.04 live cd and not the 10.10 live cd, as the 10.10 live cd gives an error if you try and run fsck on your main drive.

Hope this helps someone!

March 28th, 2011, 12:06 AM

Thank you for the reply. Yeah I did what you said...however it didn't work in ubuntu. I personally have to download partition magic as it doesn't try and mount the hard drive which means you cant run fsck.


I think the root of my problem was hard drive related so I ran the hard drive manufacturers program and that sorted the hard drive out.