View Full Version : [ubuntu] 10.10 does not load after updates. "No init found."

January 18th, 2011, 08:15 PM

I updated ubuntu (10.10) today after not doing so in a while and there was an error after it had done most of the updates. However, foolishly, I payed little attention to this and i rebooted my computer for the rest of updates to take effect and received the error:

No init found. Try passing init= bootarg

I received this error no matter which kernel I tried...

After researching i downloaded and installed the iso onto USB stick. This however also failed because for some reason it did not know the location of vmlinuz and initrd.lz....

However, when i inserted the code so it would know the location of these files it loads somewhat but eventually comes up with the same "init" error. Can anyone help?

Thank you.

January 31st, 2011, 03:10 PM
I'm getting this same problem on 10.10. I did update recently as well, but I don't think it had problems during the update. I had my computer basically lock up and decided I couldn't wait any longer since I needed to go to bed and when I tried booting it the next day I'm getting this same issue. I did some searching and the only thing I could find was to try booting into a live session and running this:
sudo fsck /dev/sda3sudo fsck /dev/sda4

I haven't tried it yet, but I wasn't so sure this would fix the issue.

February 4th, 2011, 01:37 PM
I have the same problem after yesterday's updates.
The update process went without any problems.

PS: the fsck on the root partions fixed the problem. May be there should be better error message.